Find the answer to your Linux question:
Results 1 to 5 of 5
Hi guys... i have problems with my setup, it was my first time to use debian... actually i wasnt able to use it yet... i can't boot Debian Linux from ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2010
    Posts
    3

    Multiboot with Windows7 and Debian using GAG


    Hi guys... i have problems with my setup, it was my first time to use debian... actually i wasnt able to use it yet... i can't boot Debian Linux from GAG.

    i decided to use GAG because it is much easier adding/deleting OSs...

    here's my setup
    2 HD's:
    500GB Sata with 4 partitions
    *40G Windows7 amd64 partition: working fine
    *30G Debian5 amd64: currently /dev/sdb3 ---->>> can't boot
    *30G : reserved for freebsd
    *400G : NTFS Data partition

    200GB IDE with 2 partitions
    *30G : reserved for testing new Operating Systems
    *170G : NTFS Backup partition


    i am planning for this kinda setup: 4 OS using GAG
    Windows7, Debian, FreeBSD, Test Linux Distro

    my initial setup was only Windows7 and Ubuntu... It was all OK booting 2 OSs using GAG.

    then I decided to change my primary linux distro(Ubuntu) to Debian

    so I formatted /dev/sdb3 and replaced it with Debian... according to GAGs FAQs, in order to boot linux distros from GAG, you should install GRUB to where LINUX was installed.... just like what i did with Ubuntu... i installed grub in /dev/sdb3

    now I configured GAG and added the Debian partition in its boot menu.... here's the problem.... when i hit the key to boot my Debian partition... GRUB menu shows up but cannot continue booting.... it says Error 22: Cant find partition.....

    i tried checking/editing GRUB menu....
    root(hd1,2)
    kernel bla bla bla.... root=/dev/sdb3

    dont know whats the problem, GRUB menu shows/points to the correct partition

    you might ask me maybe its GAG's problem.... im sure its not... coz i haven't had problems doing the same exact thing with Ubuntu 9.10... i may have missed out something....

    i also tried booting Ubuntu live CD and did this hoping it would fix it...
    checked partitions just to make sure:
    sudo fdisk -l
    sudo blkid

    indeed Debian is installed in /dev/sdb3:

    sudo mount /dev/sdb3 /mnt
    sudo mount -o bind /dev /mnt/dev
    sudo mount -o bind /proc /mnt/proc
    sudo chroot /mnt
    grub-install /dev/sdb3
    reboot....


    still can't boot...

    any thots? thanks....

  2. #2
    Just Joined!
    Join Date
    Jan 2010
    Posts
    35
    If you are making it to GRUB then I agree and believe that GAG is not an issue. I don't see it in your post, but am deciding to ask anyways; Do you maybe have a seperate partition containg your /boot (you can also use the mount command and/or sfdisk -l to view partitions)? Also, double check to make sure the image files (vmlinuz and initrd) are the correct files with the proper permissions and in the correct location.

    Not sure if anything here will help, but maybe it will give you some ideas.

  3. #3
    Linux User
    Join Date
    Dec 2007
    Location
    Idaho USA
    Posts
    359
    In the GRUB menu try root(hd0,2), if GAG is installed on the same hdd.

  4. #4
    Just Joined!
    Join Date
    Jan 2010
    Posts
    3
    i tried removing the ide drive... and changed from
    root(hd1,2) -> root(hd0,2)
    kernel /boot/vmlinuz .... root=/dev/sdb3 -> root=/dev/sda3

    this works... may its an ide/sata issue? hurrrr..

    ide drive is always set as my first hd?
    is it always that way? what if i want my Sata drive as my hd0?

  5. #5
    Just Joined!
    Join Date
    Jan 2010
    Posts
    3
    phew... figured out my own problem.. its not a SATA and IDE issue... its just a matter of disabling PCI BUS Mastering in Bios

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •