Find the answer to your Linux question:
Results 1 to 6 of 6
Hello All, I am trying to install the TPUART driver ( http://www.hto.fh-deggendorf.de/komm/anlage/readme.txt ) on my notebook. Debian GNU/Linux 2.4.24 The problem is that the Makefile assumes that I have a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Posts
    5

    TPUART driver: /usr/src/linux/ directory not present


    Hello All,
    I am trying to install the TPUART driver (http://www.hto.fh-deggendorf.de/komm/anlage/readme.txt) on my notebook.
    Debian GNU/Linux 2.4.24
    The problem is that the Makefile assumes that I have a /usr/src/linux directory in my computer and it is not the case.
    Instead, under /usr/src/ I have:
    - Kernel-headers-2.4.24-1
    - Kernel-headers-2.4.24-1-686
    - Kernel-source-2.4.24
    - Kernel-source-2.4.24.tar.bz2
    Therefore, running 'make' results in:

    "gcc -Wall -D__KERNEL__ -DMODVERSIONS -D__SMP__ -D__RTL__ -D_LOOSE_KERNEL_NAMES -DMODULE -include /usr/src/linux/include/modversions.h -O2 -fstrict-prototypes -fno-strict-aliasing -pipe -fomit-frame-pointer -DVERSION=\"0.03\" -I/usr/src/linux/include -I. -I/usr/src/rtlinux/include -I/usr/src/rtlinux/include/compat -I/usr/src/rtlinux/include/posix -c bmrecv.c
    cc1: error: unrecognized option `-fstrict-prototypes'
    make: *** [bmrecv.o] Error 1"

    I have tried to edit the CFLAGS in the Makefile so that it matches with my installation. But it does not work. (I dont have an rtlinux directory neither).

    My questions are:
    Does anyone know why I dont have the /usr/src/linux directory?
    Has anyone ever installed the TPUART driver before and found how to solve this problem?

    Thanks in advance for any hint!
    Alex

  2. #2
    Linux Newbie
    Join Date
    Oct 2004
    Location
    Manchester, England
    Posts
    165
    the /usr/src/linux directory is just a link to your actual source directory, it just helps for compatabilty, it's easier for software to reference the linux directory than it is to find out which source you are using.
    usually when you are configuring/installing a kernel you will set up this sim link yourself. So all a program has to do when it needs info from your kernel source is look in the linux directory

    just do this

    Code:
    ln -s /usr/src/Kernel-source-2.4.24 /usr/src/linux
    and you will have your linux directory
    The way a link works is that you enter the linux directory and it sees that it is a link to somewhere else, so it is actually using the real directory.

    There are 2 types of links, Hard and Soft. Play with google and see if you can see what the difference is

  3. #3
    Just Joined!
    Join Date
    Oct 2004
    Posts
    5
    Thanks for your advise!
    However, now it remains another question:
    There is another directory that does not appear in my system: the /usr/src/rtlinux directory, which is also specified in the Makefile.
    I suppose I need to create another link with:
    Code:
    ln -s /usr/src/???? /usr/src/rtlinux
    Where should this link point to?

  4. #4
    Linux Newbie
    Join Date
    Oct 2004
    Location
    Manchester, England
    Posts
    165
    have you tried to configure it since the linux link ?

  5. #5
    Just Joined!
    Join Date
    Oct 2004
    Posts
    5
    Hello,
    No I did not try the linux link before my last post.
    Now I have tried and it keeps on giving the same error as before.

    Anyway, If I create a link /usr/src/linux pointing to /usr/src/kernel-source-2.4.24-1/ then the path to files like 'modversions.h' (which are specified in CFLAGS) are not set correctly.
    In this case, modversions.h is located in my system under /usr/src/kernel-headers-2.4.24-1-686/include/linux/
    I have tried also to point /usr/src/linux/ to the above-mentioned directory, but it gives the same error:

    unrecognized option '-fstrict-prototypes'

    I have also tried to edit the CFLAGS accordingly but the same error appears again, so.... perhaps the source of the error is because something is missing in my installation??

    cheers!

  6. #6
    Linux Newbie
    Join Date
    Oct 2004
    Location
    Manchester, England
    Posts
    165
    make sure you have the correct minimum versions of any software that is required, especially the compiler

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •