Find the answer to your Linux question:
Results 1 to 3 of 3
All my LC environment variables are currently set to POSIX at boot, though I can't find the startup script that does this. I've grepped through /etc/rcS.d and /etc/rc2.d but no ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer hazel's Avatar
    Join Date
    May 2004
    Location
    Harrow, UK
    Posts
    1,281

    How do I permanently change my locale from POSIX to en_GB?


    All my LC environment variables are currently set to POSIX at boot, though I can't find the startup script that does this. I've grepped through /etc/rcS.d and /etc/rc2.d but no luck.

    In /etc/default/locale, LANG is set to en_GB.UTF-8, which is my preferred locale. But this doesn't stop all the LC's being set to POSIX. Consequently, my dates follow the American convention, which I find hard to read.

    I tried resetting with update-locale LC_TIME=en_GB.UTF-8. This changed all the locales to en_GB but only for the session. When I rebooted, everything went back to POSIX. The only change is that en_GB.utf-8 is now in the /etc/default/locale file as the value of LC_TIME as well as LANG.

    How do I change this info permanently?
    "I'm just a little old lady; don't try to dazzle me with jargon!"
    www.hrussman.entadsl.com

  2. #2
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,045
    Quote Originally Posted by hazel View Post
    How do I change this info permanently?
    do changes in /etc/environment over-ride the settings?

  3. #3
    Linux Engineer hazel's Avatar
    Join Date
    May 2004
    Location
    Harrow, UK
    Posts
    1,281
    The only thing I've got in /etc/environment is LANG, which is set to en_GB.UTF-8.

    I've now got round the problem of the panel clock by simply choosing a different format - one that explicitly gets day, month and year, and puts them in what I consider to be the right order rather than relying on a locale default. But I'm still puzzled by the POSIX thing. I put an update_locale instruction in rc.local to set LC_TIME to en_GB but it doesn't seem to have worked.

    Oops! I've just found a format error in that instruction! I'll correct it and then report back.
    "I'm just a little old lady; don't try to dazzle me with jargon!"
    www.hrussman.entadsl.com

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •