Find the answer to your Linux question:
Results 1 to 3 of 3
Hi all, i'm trying to configure my dhcp server but without success. i've installed dhcpd apt-get install dhcpd-server then i've added the following line to my dhcpd.conf host foo{ hardware ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2010
    Posts
    5

    [SOLVED] Configuration of dhcp


    Hi all,
    i'm trying to configure my dhcp server but without success.
    i've installed dhcpd
    apt-get install dhcpd-server
    then i've added the following line to my dhcpd.conf
    host foo{
    hardware ethernet 00:00:24:C9:5A: D0;
    fixed-adress 169.254.81.51;
    filename "pxelinux.0";
    }
    " i've followed this tuto "hp://roland.entierement.nu/pages/debian-on-soekris-howto.html"

    i got this error:
    ]
    The error was:
    Internet Systems Consortium DHCP Server V3.1.1
    Copyright 2004-2008 Internet Systems Consortium.
    All rights reserved.
    For info, please visit....
    /etc/dhcp3/dhcpd.conf line 22: semicolon expected.
    fixed-adress 169.
    ^
    Configuration file errors encountered -- exiting
    Information about my configuration files :

    for : cat /etc/network/interfaces
    # The loopback network interface
    auto lo
    iface lo inet loopback

    # The primary network interface
    allow-hotplug eth0
    iface eth0 inet dhcp
    debian:/# ifconfig
    eth0 Link encap:Ethernet HWaddr 00:1d:92:a9:3e:de
    inet adr:169.254.81.51 Bcast:169.254.255.255 Masque:255.255.0.0
    adr inet6: fe80::21d:92ff:fea9:3ede/64 Scope:Lien
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:89 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 lg file transmission:1000
    RX bytes:0 (0.0 B) TX bytes:15921 (15.5 KiB)
    Interruption:18
    debian:/etc/network# dhclient
    Internet Systems Consortium DHCP Client V3.1.1
    Copyright 2004-2008 Internet Systems Consortium.
    All rights reserved.
    For info, please visit ....
    Listening on LPF/eth0/00:1d:92:a9:3e:de
    Sending on LPF/eth0/00:1d:92:a9:3e:de
    Sending on Socket/fallback
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 3
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 4
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 6
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 15
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 16
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 1
    No DHCPOFFERS received.
    No working leases in persistent database - sleeping.
    i've attached my dhcpd.conf.
    Thank you for any help
    Attached Files Attached Files

  2. #2
    Linux Engineer psic's Avatar
    Join Date
    Nov 2004
    Location
    Ljubljana, Slovenia
    Posts
    1,205
    Well, you have a typo in your dhcpd.conf - which the error mentions as well. You spelled 'address' as 'adress' (it should be fixed-address).

    That link you have doesn't have anything do do with dhcpd, but here's a good how-to on the subject.

    Hope this helps.
    Stumbling around the 'net:
    www.cloudyuseful.com

  3. #3
    Just Joined!
    Join Date
    Mar 2010
    Posts
    5
    thank you for your help psic, it works using this configuration

    ddns-update-style none;
    option domain-name "clowny.com";
    option domain-name-servers 192.168.1.1;
    default-lease-time 600;
    max-lease-time 7200;
    log-facility local7;
    allow booting;
    allow bootp;

    subnet 192.168.1.0 netmask 255.255.255.0 {
    range 192.168.1.200 192.168.1.253;
    option broadcast-address 192.168.1.255;
    option domain-name-servers 192.168.1.1;
    }

    host hjr {
    hardware ethernet 00:00:24:C6:33:20;
    filename "pxelinux.0";
    }

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •