Find the answer to your Linux question:
Results 1 to 5 of 5
G'day everyone, I'm having difficulties mounting an FTP address to my file system automatically during boot. After a bit of research I have discovered a package called curlftpfs, I've installed ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2010
    Location
    Sydney, Australia
    Posts
    68

    Mount FTP in /etc/fstab


    G'day everyone,

    I'm having difficulties mounting an FTP address to my file system automatically during boot. After a bit of research I have discovered a package called curlftpfs, I've installed this package using aptitude and I had no errors.

    I've successfully mounted an FTP address manually using curlftpfs at the command line and proved to myself that this is working as it should...However, I can't get this to mount automatically and I am receiving the following error during boot when I try and mount it through /etc/fstab...

    Error connecting to ftp: Failed to connect to (IP address of server): Network is unreachable

    My research indicates this package should be able to do this.

    I'm still a learner when it comes to Linux, but could this be because TCP/IP services are not started at the time of mounting the filesystems? I've tried a continuous ping at this computer whilst it is booting and I don't get a response until after /etc/fstab has been processed. If this is the reason, can I start them these processes earlier?

    Another option would be to have a script/command run when the computer boots, but prior to MySQL loading. If this is possible, it would also satisfy my problems.

    Thank you in advance for any suggestions you have in solving my problem.

    Cheers,

    Griffo

  2. #2
    Linux Guru
    Join Date
    Nov 2007
    Posts
    1,762
    but could this be because TCP/IP services are not started at the time of mounting the filesystems?
    Yes. I generally put this type of command in /etc/rc.local on Debian systems and add a comment in the motd about any non-standard startup scripts/commands.

  3. #3
    Just Joined!
    Join Date
    Jan 2010
    Location
    Sydney, Australia
    Posts
    68
    Thanks for your reply, I tried what you suggested but it is too late in the boot sequence...Is it possible to start this earlier, possibly even the first service after the message appears:

    INIT: Entering runlevel: 2

    Cheers,

    Griffo

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Nov 2007
    Posts
    1,762
    A) Write a small script to do your mount and add it to the start scripts in rc2.d in whatever order you want.

    B) Disable the startup of whatever you're concerned about in rc2.d and manually add it to rc.local so it's called after the curlftpfs mount.

  6. #5
    Just Joined!
    Join Date
    Jan 2010
    Location
    Sydney, Australia
    Posts
    68
    That is exactly what I was after, thank you for pointing me in the right direction.

    There were too many scripts to move into /etc/rc.local...well I was just a little lazy to move all of them...but I created a script and gave it a lower S## number than the MySQL scripts and it worked perfectly.

    Thank you again, this had been bothering me for a couple of days now.

    One last question:
    Does anyone know of a tutorial or study guide that can explain the boot process of a Linux operating system, from BIOS to login? I think it would help me a lot with my own troubleshooting and greater understanding of Linux.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •