Find the answer to your Linux question:
Results 1 to 7 of 7
I have installed Debian Lenny 5 and am trying to access the server via SSH port 22 but it keeps telling me : Connection refused Any ideas how to enable ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2008
    Posts
    1

    SSH on Debian 5.0


    I have installed Debian Lenny 5 and am trying to access the server via SSH port 22 but it keeps telling me : Connection refused

    Any ideas how to enable this SSH on Debian server for connections ???

  2. #2
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    did you install ssh package yet?

    can you ping machine?

  3. #3
    Linux Enthusiast scathefire's Avatar
    Join Date
    Jan 2010
    Location
    Western Kentucky
    Posts
    626
    maybe something like:
    /etc/rc.d/init.d/sshd start
    linux user # 503963

  4. #4
    Just Joined!
    Join Date
    Jan 2008
    Posts
    53
    Quote Originally Posted by gpbworld View Post
    I have installed Debian Lenny 5 and am trying to access the server via SSH port 22 but it keeps telling me : Connection refused

    Any ideas how to enable this SSH on Debian server for connections ???
    Are you shure you have installed ssh on the system?

    do it with

    apt-get install $package-name

    or with the synaptic via X11.

    then make shure it is running:

    ps -efa | grep sshd

    if it is not the run

    /etc/init.d/ssh start

  5. #5
    Just Joined!
    Join Date
    May 2010
    Location
    San Diego / Tijuana
    Posts
    4
    "apt-get install $package-name"

    Where "$package-name" could be ssh

    aptitude install ssh

    Debian meta-package ssh includes both openssh-client and openssh-server. Also make sure your firewall (iptables, bastille, etc) isn't blocking the port.

  6. #6
    Just Joined!
    Join Date
    May 2010
    Posts
    5
    You can also try:

    netstat -tulpn and see if anything is bound to port 22. If there is it is probably ssh server running.

  7. #7
    Linux Engineer Kieren's Avatar
    Join Date
    Aug 2007
    Location
    England
    Posts
    848
    To install SSH server you need to run the following command as root:

    Code:
    apt-get install openssh-server
    You should then be able to SSH into the server
    Linux User #453176

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •