Find the answer to your Linux question:
Results 1 to 5 of 5
Hi folks, Debian 5.0 32bit On running "sudo aptitude dist-upgrade" I encountered following problem; $ sudo aptitude dist-upgrade Code: Reading package lists... Done Building dependency tree Reading state information... Done ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,802

    Uable to run "dist-upgrade"


    Hi folks,

    Debian 5.0 32bit

    On running "sudo aptitude dist-upgrade" I encountered following problem;
    $ sudo aptitude dist-upgrade
    Code:
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Reading extended state information      
    Initializing package states... Done
    Reading task descriptions... Done  
    The following packages are BROKEN:
      libmono-cairo1.0-cil libmono-cairo2.0-cil libmono-winforms1.0-cil 
      libmono-winforms2.0-cil mono-mcs monodoc-base 
    The following NEW packages will be installed:
      libmono-webbrowser0.5-cil{a} 
    6 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 2864kB of archives. After unpacking 90.1kB will be freed.
    The following packages have unmet dependencies:
      monodoc-base: Depends: libc6 (>= 2.9) but 2.7-18lenny2 is installed. or
                             libc6.1 (>= 2.9) which is a virtual package. or
                             libc0.1 (>= 2.9) which is a virtual package.
      libmono-winforms1.0-cil: Depends: libc6 (>= 2.9) but 2.7-18lenny2 is installed. or
                                        libc6.1 (>= 2.9) which is a virtual package. or
                                        libc0.1 (>= 2.9) which is a virtual package.
      libmono-cairo2.0-cil: Depends: libcairo2 (>= 1.8.0-2) but 1.6.4-7 is installed.
      libmono-winforms2.0-cil: Depends: libc6 (>= 2.9) but 2.7-18lenny2 is installed. or
                                        libc6.1 (>= 2.9) which is a virtual package. or
                                        libc0.1 (>= 2.9) which is a virtual package.
      mono-mcs: Depends: libc6 (>= 2.9) but 2.7-18lenny2 is installed. or
                         libc6.1 (>= 2.9) which is a virtual package. or
                         libc0.1 (>= 2.9) which is a virtual package.
      libmono-cairo1.0-cil: Depends: libcairo2 (>= 1.8.0-2) but 1.6.4-7 is installed.
    The following actions will resolve these dependencies:
    
    Keep the following packages at their current version:
    libmono-cairo1.0-cil [1.9.1+dfsg-6 (stable, now)]
    libmono-cairo2.0-cil [1.9.1+dfsg-6 (stable, now)]
    libmono-winforms1.0-cil [1.9.1+dfsg-6 (stable, now)]
    libmono-winforms2.0-cil [1.9.1+dfsg-6 (stable, now)]
    mono-mcs [1.9.1+dfsg-6 (stable, now)]
    monodoc-base [1.9-2 (stable, now)]
    
    Leave the following dependencies unresolved:
    libmono-webbrowser0.5-cil recommends libgluezilla
    Score is -30
    
    Accept this solution? [Y/n/q/?] Y
    No packages will be installed, upgraded, or removed.
    0 packages upgraded, 0 newly installed, 0 to remove and 6 not upgraded.
    Need to get 0B of archives. After unpacking 0B will be used.
    Do you want to continue? [Y/n/?] Y
    Writing extended state information... Done
    Reading package lists... Done             
    Building dependency tree       
    Reading state information... Done
    Reading extended state information      
    Initializing package states... Done
    Reading task descriptions... Done

    Because of;
    Code:
    The following packages are BROKEN:
      libmono-cairo1.0-cil libmono-cairo2.0-cil libmono-winforms1.0-cil 
      libmono-winforms2.0-cil mono-mcs monodoc-base 
    The following NEW packages will be installed:
    I was unable to upgrade the packages. Please help. TIA


    B.R.
    satimis

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Did you edit sources.list file or its a regular upgrade only?
    Have you tried to clean cache?
    Code:
    su -
    apt-get clean all
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,802
    Quote Originally Posted by devils casper View Post
    Did you edit sources.list file or its a regular upgrade only?
    Hi,


    After editing the source.list


    $ cat /etc/apt/sources.list
    Code:
    #deb cdrom:[Debian GNU/Linux 5.0.1 _Lenny_ - Official i386 NETINST Binary-1 20090413-22:27]/ lenny main
    
    deb http://ftp.hk.debian.org/debian/ lenny main contrib non-free
    deb-src http://ftp.hk.debian.org/debian/ lenny main contrib non-free
    
    deb http://security.debian.org/ lenny/updates main contrib non-free
    deb-src http://security.debian.org/ lenny/updates main contrib non-free
    
    deb http://volatile.debian.org/debian-volatile lenny/volatile main
    deb-src http://volatile.debian.org/debian-volatile lenny/volatile main
    
    deb http://www.backports.org/debian lenny-backports main contrib non-free
    
    deb ftp://ftp.debian-multimedia.org lenny main
    
    deb http://debian.meebey.net/pkg-mono /

    $ su -
    # apt-get clean all


    $ sudo aptitude update


    $ sudo aptitude dist-upgrade
    Code:
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Reading extended state information      
    Initializing package states... Done
    Reading task descriptions... Done  
    The following packages are BROKEN:
      libmono-cairo1.0-cil libmono-cairo2.0-cil libmono-winforms1.0-cil 
      libmono-winforms2.0-cil mono-mcs monodoc-base 
    The following NEW packages will be installed:
      libmono-webbrowser0.5-cil{a} 
    6 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 2864kB of archives. After unpacking 90.1kB will be freed.
    The following packages have unmet dependencies:
      monodoc-base: Depends: libc6 (>= 2.9) but 2.7-18lenny2 is installed. or
                             libc6.1 (>= 2.9) which is a virtual package. or
                             libc0.1 (>= 2.9) which is a virtual package.
      libmono-winforms1.0-cil: Depends: libc6 (>= 2.9) but 2.7-18lenny2 is installed. or
                                        libc6.1 (>= 2.9) which is a virtual package. or
                                        libc0.1 (>= 2.9) which is a virtual package.
      libmono-cairo2.0-cil: Depends: libcairo2 (>= 1.8.0-2) but 1.6.4-7 is installed.
      libmono-winforms2.0-cil: Depends: libc6 (>= 2.9) but 2.7-18lenny2 is installed. or
                                        libc6.1 (>= 2.9) which is a virtual package. or
                                        libc0.1 (>= 2.9) which is a virtual package.
      mono-mcs: Depends: libc6 (>= 2.9) but 2.7-18lenny2 is installed. or
                         libc6.1 (>= 2.9) which is a virtual package. or
                         libc0.1 (>= 2.9) which is a virtual package.
      libmono-cairo1.0-cil: Depends: libcairo2 (>= 1.8.0-2) but 1.6.4-7 is installed.
    The following actions will resolve these dependencies:
    
    Keep the following packages at their current version:
    libmono-cairo1.0-cil [1.9.1+dfsg-6 (stable, now)]
    libmono-cairo2.0-cil [1.9.1+dfsg-6 (stable, now)]
    libmono-winforms1.0-cil [1.9.1+dfsg-6 (stable, now)]
    libmono-winforms2.0-cil [1.9.1+dfsg-6 (stable, now)]
    mono-mcs [1.9.1+dfsg-6 (stable, now)]
    monodoc-base [1.9-2 (stable, now)]
    
    Leave the following dependencies unresolved:
    libmono-webbrowser0.5-cil recommends libgluezilla
    Score is -30
    
    Accept this solution? [Y/n/q/?] Y
    No packages will be installed, upgraded, or removed.
    0 packages upgraded, 0 newly installed, 0 to remove and 6 not upgraded.
    Need to get 0B of archives. After unpacking 0B will be used.
    Do you want to continue? [Y/n/?] Y
    Writing extended state information... Done
    Reading package lists... Done             
    Building dependency tree       
    Reading state information... Done
    Reading extended state information      
    Initializing package states... Done
    Reading task descriptions... Done
    It seems no complaint.


    B.R.
    satimis

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Comment volatile and meebey sources and check if it works. You can uncomment those after successful upgrade.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,802
    Quote Originally Posted by devils casper View Post
    Comment volatile and meebey sources and check if it works. You can uncomment those after successful upgrade.
    Comment out volatile and meebey. Ran;

    $ sudo aptitude update
    $ sudo aptitude dist-upgrade

    No complaint


    Uncomment volatile and meebey. Ran;

    $ sudo aptitude update
    $ sudo aptitude dist-upgrade

    It complained


    $ sudo aptitude dist-upgrade
    Code:
    Reading task descriptions... Done  
    The following packages are BROKEN:
      libmono-cairo1.0-cil libmono-cairo2.0-cil libmono-winforms1.0-cil 
      libmono-winforms2.0-cil mono-2.0-devel mono-gmcs mono-mcs monodoc-base 
    The following NEW packages will be installed:
      libmono-cecil-private-cil{a} libmono-webbrowser0.5-cil{a} 
    8 packages upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
    Need to get 3634kB of archives. After unpacking 438kB will be used.
    The following packages have unmet dependencies:
      monodoc-base: Depends: libc6 (>= 2.9) but 2.7-18lenny2 is installed. or
                             libc6.1 (>= 2.9) which is a virtual package. or
                             libc0.1 (>= 2.9) which is a virtual package.
      libmono-winforms1.0-cil: Depends: libc6 (>= 2.9) but 2.7-18lenny2 is installed. or
                                        libc6.1 (>= 2.9) which is a virtual package. or
                                        libc0.1 (>= 2.9) which is a virtual package.
      libmono-cairo2.0-cil: Depends: libcairo2 (>= 1.8.0-2) but 1.6.4-7 is installed.
      libmono-winforms2.0-cil: Depends: libc6 (>= 2.9) but 2.7-18lenny2 is installed. or
                                        libc6.1 (>= 2.9) which is a virtual package. or
                                        libc0.1 (>= 2.9) which is a virtual package.
      mono-mcs: Depends: libc6 (>= 2.9) but 2.7-18lenny2 is installed. or
                         libc6.1 (>= 2.9) which is a virtual package. or
                         libc0.1 (>= 2.9) which is a virtual package.
      mono-2.0-devel: Depends: libc6 (>= 2.9) but 2.7-18lenny2 is installed. or
                               libc6.1 (>= 2.9) which is a virtual package. or
                               libc0.1 (>= 2.9) which is a virtual package.
                      Depends: mono-2.0-gac (= 2.4+dfsg-2~pre1) but 2.4.2.3+dfsg-2~bpo50+1 is installed.
      libmono-cairo1.0-cil: Depends: libcairo2 (>= 1.8.0-2) but 1.6.4-7 is installed.
      mono-gmcs: Depends: libc6 (>= 2.9) but 2.7-18lenny2 is installed. or
                          libc6.1 (>= 2.9) which is a virtual package. or
                          libc0.1 (>= 2.9) which is a virtual package.
    The following actions will resolve these dependencies:
    
    Keep the following packages at their current version:
    libmono-cairo1.0-cil [1.9.1+dfsg-6 (stable, now)]
    libmono-cairo2.0-cil [1.9.1+dfsg-6 (stable, now)]
    libmono-winforms1.0-cil [1.9.1+dfsg-6 (stable, now)]
    libmono-winforms2.0-cil [1.9.1+dfsg-6 (stable, now)]
    mono-2.0-devel [1.9.1+dfsg-6 (stable, now)]
    mono-gmcs [1.9.1+dfsg-6 (stable, now)]
    mono-mcs [1.9.1+dfsg-6 (stable, now)]
    monodoc-base [1.9-2 (stable, now)]
    
    Leave the following dependencies unresolved:
    libmono-webbrowser0.5-cil recommends libgluezilla
    Score is -10
    
    Accept this solution? [Y/n/q/?] Y
    No packages will be installed, upgraded, or removed.
    0 packages upgraded, 0 newly installed, 0 to remove and 8 not upgraded.
    Need to get 0B of archives. After unpacking 0B will be used.
    Do you want to continue? [Y/n/?] Y
    Writing extended state information... Done
    Reading package lists... Done             
    Building dependency tree       
    Reading state information... Done
    Reading extended state information      
    Initializing package states... Done
    Reading task descriptions... Done

    Ran;

    # sudo apt-get clean all

    $ sudo aptitude update

    $ sudo aptitude dist-upgrade
    Code:
    $ sudo aptitude dist-upgrade
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Reading extended state information      
    Initializing package states... Done
    Reading task descriptions... Done  
    The following packages are BROKEN:
      libmono-cairo1.0-cil libmono-cairo2.0-cil libmono-winforms1.0-cil 
      libmono-winforms2.0-cil mono-2.0-devel mono-gmcs mono-mcs monodoc-base 
    The following NEW packages will be installed:
      libmono-cecil-private-cil{a} libmono-webbrowser0.5-cil{a} 
    8 packages upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
    Need to get 3634kB of archives. After unpacking 438kB will be used.
    The following packages have unmet dependencies:
      monodoc-base: Depends: libc6 (>= 2.9) but 2.7-18lenny2 is installed. or
                             libc6.1 (>= 2.9) which is a virtual package. or
                             libc0.1 (>= 2.9) which is a virtual package.
      libmono-winforms1.0-cil: Depends: libc6 (>= 2.9) but 2.7-18lenny2 is installed. or
                                        libc6.1 (>= 2.9) which is a virtual package. or
                                        libc0.1 (>= 2.9) which is a virtual package.
      libmono-cairo2.0-cil: Depends: libcairo2 (>= 1.8.0-2) but 1.6.4-7 is installed.
      libmono-winforms2.0-cil: Depends: libc6 (>= 2.9) but 2.7-18lenny2 is installed. or
                                        libc6.1 (>= 2.9) which is a virtual package. or
                                        libc0.1 (>= 2.9) which is a virtual package.
      mono-mcs: Depends: libc6 (>= 2.9) but 2.7-18lenny2 is installed. or
                         libc6.1 (>= 2.9) which is a virtual package. or
                         libc0.1 (>= 2.9) which is a virtual package.
      mono-2.0-devel: Depends: libc6 (>= 2.9) but 2.7-18lenny2 is installed. or
                               libc6.1 (>= 2.9) which is a virtual package. or
                               libc0.1 (>= 2.9) which is a virtual package.
                      Depends: mono-2.0-gac (= 2.4+dfsg-2~pre1) but 2.4.2.3+dfsg-2~bpo50+1 is installed.
      libmono-cairo1.0-cil: Depends: libcairo2 (>= 1.8.0-2) but 1.6.4-7 is installed.
      mono-gmcs: Depends: libc6 (>= 2.9) but 2.7-18lenny2 is installed. or
                          libc6.1 (>= 2.9) which is a virtual package. or
                          libc0.1 (>= 2.9) which is a virtual package.
    The following actions will resolve these dependencies:
    
    Keep the following packages at their current version:
    libmono-cairo1.0-cil [1.9.1+dfsg-6 (stable, now)]
    libmono-cairo2.0-cil [1.9.1+dfsg-6 (stable, now)]
    libmono-winforms1.0-cil [1.9.1+dfsg-6 (stable, now)]
    libmono-winforms2.0-cil [1.9.1+dfsg-6 (stable, now)]
    mono-2.0-devel [1.9.1+dfsg-6 (stable, now)]
    mono-gmcs [1.9.1+dfsg-6 (stable, now)]
    mono-mcs [1.9.1+dfsg-6 (stable, now)]
    monodoc-base [1.9-2 (stable, now)]
    
    Leave the following dependencies unresolved:
    libmono-webbrowser0.5-cil recommends libgluezilla
    Score is -10
    
    Accept this solution? [Y/n/q/?] Y
    No packages will be installed, upgraded, or removed.
    0 packages upgraded, 0 newly installed, 0 to remove and 8 not upgraded.
    Need to get 0B of archives. After unpacking 0B will be used.
    Do you want to continue? [Y/n/?] Y
    Writing extended state information... Done
    Reading package lists... Done             
    Building dependency tree       
    Reading state information... Done
    Reading extended state information      
    Initializing package states... Done
    Reading task descriptions... Done
    But still the same !!!


    B.R.
    satimis

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •