Find the answer to your Linux question:
Results 1 to 3 of 3
Hello, as alsaconf as been removed from alsa-utils in Squeeze, how to configure ALSA ? Which replacement for alsaconf ? Debian is squeeze. Package alsa-utils v1.0.22-1 Currently alsamixer is running ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Dec 2008
    Location
    Luxembourg
    Posts
    136

    Squeeze and ALSA : how to configure without alsaconf ?


    Hello,

    as alsaconf as been removed from alsa-utils in Squeeze, how to configure ALSA ?
    Which replacement for alsaconf ?

    Debian is squeeze.
    Package alsa-utils v1.0.22-1
    Currently alsamixer is running fine for setup but i.e. speaker-test produce no sound.
    Previous Lenny installation was working once alsaconf ran.

    Thanks.
    Bruno

  2. #2
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,144
    Howdy Bruno. Though I don't run Debian Vanilla Squeeze. My Netbook runs AntiX 8.5 that is built on Mepis Kernel and Debian Squeeze repositories and Applications.

    Seems Debian wants you try

    For release Squeeze or any later release, alsaconf is no longer available in package alsa-utils. So try to configure alsa by running the command 'alsactl init' as root. Just ignore the error message like 'Unknown hardware' (this issue said to be fixed in alsa-utils .20), then reboot and try to test your sound. For more details please see this thread.

    You can also try to detect and configure your sound card manually.

    *

    If you have a PCI soundcard, do a 'lspci -v' to list all available pci devices. The list will most probably include a reference to a multimedia audio device: that is your SoundCard.
    *

    For a USB card, use hotplug.

    You could now have a look at the ALSA's soundcard-matrix to find out which driver name can be used for the chipset you found.
    From

    ALSA - Debian Wiki

    Debian dropped the smxi tools from it's releases. I find it a Useful tool for everything from getting system info using inxi script and kernel upgrades, app installs, video driver installs also. Mepis and AntiX come with smxi and debian used to also. But for some reason dropped it. You can install smxi and all related tools

    smxi sgfxi svmi rbxi :: home page

    smxi sgfxi svmi :: How to Install the Scripts

    I can't run smxi in my new Ubuntu 10.04 installs on my Desktops. But I can install and run the inxi script in my Ubuntu installs and even in Puppy Linux also. It is a good info tool.

    Code:
    $ inxi -F
    System:    Host antiX1 Kernel 2.6.32-1-mepis-smp i686 (32 bit) Distro antiX-M8.5 Marek Edelman 11 April 2010
    CPU:       Single core Intel Celeron M (UP) cache 512 KB flags (nx sse sse2) bmips 1801.3 clocked at 900.144 MHz
    Graphics:  Card Intel Mobile 915GM/GMS/910GML Express Graphics Controller X.Org 1.6.5 Res: 800x600@61.0hz
               GLX Renderer Software Rasterizer GLX Version 2.1 Mesa 7.7.1-DEVEL Direct Rendering Yes
    Audio:     Card Intel 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller driver HDA Intel BusID: 00:1b.0
               Sound: Advanced Linux Sound Architecture Version 1.0.21
    Network:   Card-1 Atheros AR5001 Wireless Network Adapter driver ath5k v: 0.6.0 BusID: 01:00.0
               Card-2 Atheros L2 100 Mbit Ethernet Adapter driver atl2 v: 2.2.3 BusID: 03:00.0
    Disks:     HDD Total Size: 26.1GB (2.1% used) 1: /dev/sda ASUS 4.0GB
               2: /dev/sdb ASUS 16.1GB 3: USB /dev/sdc DataTraveler_2.0 2.0GB
               4: USB /dev/sdd CardReader_SD0 4.0GB
    Partition: ID:/ size: 16M used: 107K (1%) fs: rootfs
    Info:      Processes 92 Uptime 1:02 Memory 125.7/2016.8MB Runlevel 5 Client Shell inxi 1.4.9
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  3. #3
    Linux Newbie
    Join Date
    Dec 2008
    Location
    Luxembourg
    Posts
    136

    SOLVED : Squeeze and ALSA : how to configure without alsaconf ?

    alsactl init
    The error message can be ignored. I reboot and sound works.

    Bye,
    Bruno

    Note:

    Dear rokytnji, good remark about AntiX as a lightweigth distro, I should certainly give a try to it. I run Squeeze on a thin client 256-Kb CPU VIA 800 Mz. Thanks for advice.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •