Find the answer to your Linux question:
Results 1 to 5 of 5
Part of my system seems to think it is off-line, while in reality it has a working internet connection. Things that make it look like it's off-line: The NetworkManager applet ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User Daan's Avatar
    Join Date
    Aug 2005
    Location
    The Netherlands
    Posts
    323

    Debian thinks it's off-line, but it is on-line.


    Part of my system seems to think it is off-line, while in reality it has a working internet connection.

    Things that make it look like it's off-line:
    • The NetworkManager applet in the Gnome system tray says no network connection.
    • Evolution starts in off-line mode.
    • Automatic updates are not working.


    How can I correct this?
    OS's I use: Debian testing, Debian stable, Ubuntu, OpenSuse 12.1, Windows 7, Windows Vista, Windows XP

  2. #2
    Linux Engineer GNU-Fan's Avatar
    Join Date
    Mar 2008
    Posts
    935
    Hi,

    the problem is the "network manager" application of Gnome. It expects to manage all the network connections by itself. But most probably you have the primary network interface enabled in /etc/network/interfaces, which is out of NM's realm.

    If this is the case, NM complains that there is no network connection, even if this is plainly wrong. The maintainer of NM was once asked on his mailing list why this is. But I don't remember the justification.

    I uninstalled the Network Manager applet, and now use only the "hardwired" ethernet connection. This solved the problem.

    The other solution is to disable the interface in the file, and then have it managed by NM.
    Debian GNU/Linux -- You know you want it.

  3. #3
    Linux User Daan's Avatar
    Join Date
    Aug 2005
    Location
    The Netherlands
    Posts
    323

    Thumbs up

    I think I have the primary interface enabled in my /etc/network/interfaces:

    Code:
    root@pecularia:/home/daan# cat /etc/network/interfaces
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    
    # The loopback network interface
    auto lo
    iface lo inet loopback
    
    # The primary network interface
    allow-hotplug eth0
    iface eth0 inet dhcp
    Anyway, uninstalling the "network-manager" package seems to have cured the problems.

    Thanks!
    OS's I use: Debian testing, Debian stable, Ubuntu, OpenSuse 12.1, Windows 7, Windows Vista, Windows XP

  4. #4
    Just Joined!
    Join Date
    Sep 2009
    Posts
    8
    Debian running in x windows has always had this problem. As long as your nic settings are correct, and you can get out on the internet, you have to live with it. Try hard coding the nic and rebooting. After several reboots it should resolve the problem. Remember, this isn't windows. The guy who wrote this code is probably in his basement right now playing xbox and yelling at his mom for interrupting a 14 hour gaming binder.
    Unfortunately, you get what you pay for, in this case its free with no support.

  5. #5
    Just Joined!
    Join Date
    Jul 2006
    Location
    localhost
    Posts
    31
    Quote Originally Posted by Daan View Post
    I think I have the primary interface enabled in my /etc/network/interfaces:

    Code:
    root@pecularia:/home/daan# cat /etc/network/interfaces
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    
    # The loopback network interface
    auto lo
    iface lo inet loopback
    
    # The primary network interface
    allow-hotplug eth0
    iface eth0 inet dhcp
    Anyway, uninstalling the "network-manager" package seems to have cured the problems.

    Thanks!
    This works flawlessly for me in Lenny, my /etc/network/interfaces contains:

    Code:
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    
    # The loopback network interface
    auto lo
    iface lo inet loopback
    
    # The primary network interface
    allow-hotplug eth0
    iface eth0 inet dhcp
    
    auto eth0
    Maybe "auto eth0" is the key here?
    According to the Debian documentation that line should only activate the interface on boot and does not seem to affect NM at all

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •