Find the answer to your Linux question:
Results 1 to 3 of 3
Hello all, I'm having a lot of trouble installing drivers for my ATI radeon graphics card. I am running Debian Lenny kernel 2.6.32.10. I cannot use the built-in open source ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2010
    Posts
    9

    ATI Radeon video drivers in debian lenny 2.6.32.10?


    Hello all,
    I'm having a lot of trouble installing drivers for my ATI radeon graphics card. I am running Debian Lenny kernel 2.6.32.10. I cannot use the built-in open source radeon drivers, just doesn't work for some reason, and neither can I install fglrx proprietary drivers.

    If I do sudo aptitude update && aptitude install fglrx-modules-2.6-$(uname -r | sed 's,.*-,,') fglrx-control fglrx-driver,

    I get this response (last output only, first lists sources as normal):

    Couldn't find any package whose name or description matched "fglrx-modules-2.6-2.6.32.10"
    Couldn't find any package whose name or description matched "fglrx-modules-2.6-2.6.32.10"
    The following NEW packages will be installed:
    fglrx-atieventsd{a} fglrx-control fglrx-driver fglrx-glx{a}
    fglrx-modules-2.6.26-2-486{a} linux-image-2.6.26-2-486{a}
    0 packages upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0B/37.8MB of archives. After unpacking 109MB will be used.

    If I go ahead and try to install anyway, despite the modules package not matching my kernel version, not very suprisingly, nothing happens. I get fglrx packeges listed as installed, but no modules, and of course, no working driver.

    Does anyone

    (a) have experience of installing the radeon open source drivers for my kernel version? any hints?
    (b) have experience of installing fglrx for my kernel? is there a fglrx-modules-2.6.32-10-686 package somewhere that I'm not finding?

    btw,
    heres my graphics card,

    01:00.0 VGA compatible controller: ATI Technologies Inc Device 9480 (prog-if 00 [VGA controller])

    sorry cant submit my sources list, contains urls (!), but I do have the usual main contrib non-free added...

    Any help would be very much appreciated
    Thanks!

  2. #2
    Just Joined! shtromm's Avatar
    Join Date
    Jun 2010
    Posts
    31
    Debian does not include this drivers, because they contain proprietary and closed source - therefore outside debian's policy. You should find those driveers here:

    Graphics Drivers & Software

    or via ubuntu

    https://help.ubuntu.com/community/BinaryDriverHowto/ATI

  3. #3
    Linux Newbie craigevil's Avatar
    Join Date
    Jun 2005
    Location
    Terra in the Milky Way
    Posts
    109
    ATIProprietary - Debian Wiki - ATIProprietary - Debian Wiki
    Debian Sid LXDE Kernel liquorix CPU Pentium IV 2.80GHz GeForce 9400 GT
    Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
    Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •