Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
I'm using XAMPP on my VPS, but if it's online for more than one day, my sites and the entire server gets extremely slow. I know it's since I'm hosting ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2010
    Posts
    9

    Stop Error Reporting?


    I'm using XAMPP on my VPS, but if it's online for more than one day, my sites and the entire server gets extremely slow.
    I know it's since I'm hosting my sites on it, it didn't happen before that.
    If I do "ps aux | less", I note this:
    Code:
    nobody    5675  0.0  1.1  51720  1488 ?        S    09:25   0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
    nobody    5676  0.0  1.1  51720  1480 ?        S    09:25   0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
    nobody    5677  0.0  1.1  51720  1480 ?        S    09:25   0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
    nobody    5678  0.0  1.1  51720  1480 ?        S    09:25   0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
    nobody    5679  0.0  1.1  51720  1480 ?        S    09:25   0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
    nobody    5680  0.0  1.1  51720  1480 ?        S    09:25   0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
    I now do this: "kill -9 5675 5676 5677 5678 5679 5680"
    What happens next?
    All of them return as another process ID, and even more (or less).
    I've commented out the Error Reporting in "php.ini", but it doesn't seem to help anything.

    How do I stop that reporting for ever?

  2. #2
    Just Joined!
    Join Date
    Jun 2010
    Posts
    9
    Does someone have an answer?

  3. #3
    Just Joined!
    Join Date
    Jun 2010
    Posts
    9
    I keep bumping, until I get some help.

  4. #4
    Just Joined!
    Join Date
    Jun 2010
    Posts
    3
    The proper way to stop XAMMP is "/opt/lampp/lampp stop" or "/opt/lampp/lampp restart"

    That looks like a normal Apache proccess tree to me, it is how Apache runs; it starts multiple "server" proccesses to handle client requests. The number of servers started at start, max number, spares, etc, can be configured by editing your httpd.conf or apache2.conf, or whatever XAMMP uses. I don't use XAMMP so I don't know exactly which file you need to edit to get the number of servers/spares down to a level that you would like. But just be aware that if you have busy sites, then you may need those extra servers.

    Have you checked /opt/lampp/logs/error_log & access_log for any errors that may be causing your server to run slow? If you want to change the way logging is handled, then that may be configured in httpd.conf or apache2.conf...depends on how XAMMP handles those things. The lines you are looking for are "ErrorLog" and "LogLevel"


    Have thought of installing a "Real" Lamp server setup on your VPS, instead of using a pre-configured XAMMP setup? Installing Apache/MySql/PHP is fairly easy on most systems.

  5. #5
    Just Joined!
    Join Date
    Jun 2010
    Posts
    9
    >>Hanzerik
    I know how to stop XAMPP itself, but I mean the Error Logging.
    I used to have a normal LAMP configuration on my server, but I couldn't get into MySQL.
    That's the reason why I now have a XAMPP configuration.

    Well, I don't know what's going on. ┐('~`;)┌

  6. #6
    Just Joined!
    Join Date
    Jun 2010
    Posts
    3
    I'm not sure I understand what you want to do. Have you checked that error.log to see if anything is being written, are the logs getting too big, why do you want to stop logging? It's a normal feature of most programs to log errors.

    If not much is being written then it's not logging that is causing your server to run slow.

  7. #7
    Just Joined!
    Join Date
    Jun 2010
    Posts
    9
    >>Hanzerik
    It's actually logging a lot.
    The latest logs are:
    Code:
    on Jul 05 11:51:19 2010] [error] [client 123.125.66.74] PHP Warning:  file_get_contents(***/?feed=rss2) [<a href='function.file-get-contents'>function.file-get-contents</a>]: failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found\r\n in /home/www/cwn/index.php on line 52
    [Mon Jul 05 11:51:36 2010] [error] [client 94.228.214.59] File does not exist: /home/www/wdg/feed
    [Mon Jul 05 11:51:36 2010] [error] [client 220.181.7.75] PHP Warning:  file_get_contents(***?feed=rss2) [<a href='function.file-get-contents'>function.file-get-contents</a>]: failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found\r\n in /home/www/cwn/index.php on line 52
    [Mon Jul 05 11:53:06 2010] [error] [client 119.63.193.56] File does not exist: /home/www/mkcw/robots.txt
    [Mon Jul 05 11:54:40 2010] [error] [client 24.217.234.55] File does not exist: /home/www/yh/favicon.ico
    [Mon Jul 05 11:54:43 2010] [error] [client 24.217.234.55] File does not exist: /home/www/yh/favicon.ico
    [Mon Jul 05 12:02:06 2010] [error] [client 220.181.7.31] File does not exist: /home/www/mkcw/robots.txt
    [Mon Jul 05 12:36:07 2010] [warn] [client 123.125.66.87] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed
    [Mon Jul 05 12:36:08 2010] [warn] [client 220.181.7.61] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed
    [Mon Jul 05 12:46:00 2010] [error] [client 207.46.13.90] File does not exist: /home/www/wdg/robots.txt
    [Mon Jul 05 12:46:58 2010] [error] [client 207.46.13.90] File does not exist: /home/www/wdg/over-wdg
    [Mon Jul 05 13:33:58 2010] [error] [client 118.69.140.192] File does not exist: /home/www/yh/favicon.ico
    [Mon Jul 05 13:45:54 2010] [error] [client 220.181.7.39] File does not exist: /home/www/mkcw/robots.txt
    [Mon Jul 05 13:51:25 2010] [error] [client 218.174.4.244] File does not exist: /home/www/mkcw/favicon.ico
    [Mon Jul 05 13:51:26 2010] [error] [client 218.174.4.244] File does not exist: /home/www/mkcw/favicon.ico
    [Mon Jul 05 13:51:28 2010] [error] [client 218.174.4.244] File does not exist: /home/www/mkcw/favicon.ico
    [Mon Jul 05 13:58:18 2010] [error] [client 188.168.85.131] File does not exist: /home/www/wdg/feed
    [Mon Jul 05 14:02:54 2010] [error] [client 66.249.65.240] File does not exist: /home/www/mkcw/robots.txt
    [Mon Jul 05 14:15:52 2010] [error] [client 207.46.204.243] File does not exist: /home/www/cws/robots.txt
    [Mon Jul 05 14:16:28 2010] [warn] [client 207.46.204.243] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed
    [Mon Jul 05 14:20:31 2010] [error] [client 220.181.7.99] File does not exist: /home/www/cws/robots.txt
    [Mon Jul 05 14:36:42 2010] [error] [client 67.195.115.32] File does not exist: /home/www/yh/robots.txt
    [Mon Jul 05 14:47:28 2010] [error] [client 67.195.115.213] File does not exist: /home/www/mkcw/robots.txt
    [Mon Jul 05 15:21:49 2010] [error] [client 66.249.65.252] File does not exist: /home/www/yh/robots.txt
    [Mon Jul 05 15:40:26 2010] [error] [client 94.228.214.59] File does not exist: /home/www/wdg/feed
    [Mon Jul 05 15:40:27 2010] [error] [client 220.181.7.85] PHP Warning:  file_get_contents(***/?feed=rss2) [<a href='function.file-get-contents'>function.file-get-contents</a>]: failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found\r\n in /home/www/cwn/index.php on line 52
    [Mon Jul 05 15:46:56 2010] [error] [client 94.228.214.59] File does not exist: /home/www/wdg/feed
    [Mon Jul 05 15:46:56 2010] [error] [client 123.125.66.133] PHP Warning:  file_get_contents(***/?feed=rss2) [<a href='function.file-get-contents'>function.file-get-contents</a>]: failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found\r\n in /home/www/cwn/index.php on line 52
    [Mon Jul 05 16:09:35 2010] [error] [client 207.46.199.179] File does not exist: /home/www/wdg/robots.txt
    [Mon Jul 05 16:43:34 2010] [error] [client 94.228.214.59] File does not exist: /home/www/wdg/feed
    [Mon Jul 05 16:43:34 2010] [error] [client 123.125.66.61] PHP Warning:  file_get_contents(***/?feed=rss2) [<a href='function.file-get-contents'>function.file-get-contents</a>]: failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found\r\n in /home/www/cwn/index.php on line 52
    [Mon Jul 05 16:46:02 2010] [error] [client 94.228.214.59] File does not exist: /home/www/wdg/feed
    [Mon Jul 05 16:46:02 2010] [error] [client 220.181.7.69] PHP Warning:  file_get_contents(***/?feed=rss2) [<a href='function.file-get-contents'>function.file-get-contents</a>]: failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found\r\n in /home/www/cwn/index.php on line 52
    [Mon Jul 05 16:46:23 2010] [error] [client 220.181.7.69] PHP Warning:  file_get_contents(^^/cms/raymii.rss) [<a href='function.file-get-contents'>function.file-get-contents</a>]: failed to open stream: Geen route naar host in /home/www/cwn/index.php on line 52
    [Mon Jul 05 16:48:17 2010] [error] [client 189.15.81.41] File does not exist: /home/www/yh/favicon.ico
    [Mon Jul 05 16:48:20 2010] [error] [client 189.15.81.41] File does not exist: /home/www/yh/favicon.ico
    [Mon Jul 05 16:58:41 2010] [error] [client 87.162.188.246] File does not exist: /home/www/mkcw/favicon.ico
    [Mon Jul 05 16:58:42 2010] [error] [client 87.162.188.246] File does not exist: /home/www/mkcw/favicon.ico
    [Mon Jul 05 17:54:17 2010] [error] [client 117.204.171.219] File does not exist: /home/www/yh/favicon.ico
    [Mon Jul 05 17:54:20 2010] [error] [client 117.204.171.219] File does not exist: /home/www/yh/favicon.ico
    [Mon Jul 05 18:16:27 2010] [warn] [client 119.63.193.55] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed
    [Mon Jul 05 18:16:27 2010] [warn] [client 119.63.193.55] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed
    [Mon Jul 05 18:28:21 2010] [error] [client 119.63.198.29] File does not exist: /home/www/cws/robots.txt
    [Mon Jul 05 18:42:33 2010] [error] [client 82.176.224.154] File does not exist: /home/www/mkcw/favicon.ico
    [Mon Jul 05 18:42:50 2010] [error] [client 82.176.224.154] File does not exist: /home/www/mkcw/favicon.ico
    [Mon Jul 05 18:42:54 2010] [error] [client 82.176.224.154] File does not exist: /home/www/mkcw/favicon.ico
    [Mon Jul 05 18:43:42 2010] [error] [client 82.176.224.154] File does not exist: /home/www/mkcw/favicon.ico
    [Mon Jul 05 18:43:45 2010] [error] [client 82.176.224.154] File does not exist: /home/www/mkcw/favicon.ico
    [Mon Jul 05 18:43:49 2010] [error] [client 82.176.224.154] File does not exist: /home/www/mkcw/favicon.ico
    [Mon Jul 05 18:43:51 2010] [error] [client 82.176.224.154] File does not exist: /home/www/mkcw/favicon.ico
    [Mon Jul 05 18:46:28 2010] [error] [client 82.176.224.154] File does not exist: /home/www/mkcw/favicon.ico
    [Mon Jul 05 18:48:02 2010] [error] [client 207.46.199.39] File does not exist: /home/www/yh/robots.txt
    [Mon Jul 05 18:49:11 2010] [error] [client 82.176.224.154] File does not exist: /home/www/mkcw/favicon.ico
    ** and ^^ = URL's, but I seem to need 15 posts or more, in order to 'post' them.

  8. #8
    Just Joined!
    Join Date
    Jun 2010
    Posts
    3
    Those errors for favicon.ico and robots.txt are not bad, they are just saying that the client's browser is looking for a favicon.ico in the web root, and some scanners/data miners are looking for a robots.txt file in the web root.

    You can make your own favicon.ico files by googling favicon generator. A favicon is the little picture you see in your browsers address bar over on the far left.

    Basically robots.txt is a file that tells web crawling robots...data miners, to not bother crawling your website for data. Google robots.txt

    But looking at that short log, it doesn't show much logging going on, nothing to cause a webserver to slow down a system. Now if you were getting repetitious errors every few seconds or so, then yes you could have issues. But I just can't see that type of logging causing your problem.

    Suggestions:
    Take a look at line 52 of your index.php to see what is causing that PHP error.

    The "Includes" error looks like it is telling the client that Server Side Includes are turned off for whatever directory they are looking at. You might have to bump access.log times/ip's) against the error.log (times/ip's) to see what directory they are looking in at the time of these "Includes" errors. Then edit whatever file is controlling that directory's directives.

  9. #9
    Just Joined!
    Join Date
    Jun 2010
    Posts
    9
    >>Hanzerik
    I've added Favicon.ico and Robots.txt to all my domain names.
    I've also remade the one with the RSS problems from scratch, without RSS. (It was a website with RSS of all my WordPress-based sites, on 1 single page).
    Hope it'll work.
    *Fingers crossed*

  10. #10
    Just Joined!
    Join Date
    Jun 2010
    Posts
    9
    Update, the problem still didn't end.
    Code:
    client319:/opt/lampp/logs# more error_log | tail -200
    [Mon Jul 05 19:17:04 2010] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
    [Mon Jul 05 19:17:04 2010] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Mon Jul 05 19:17:04 2010] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
    [Mon Jul 05 19:17:04 2010] [notice] Digest: generating secret for digest authentication ...
    [Mon Jul 05 19:17:04 2010] [notice] Digest: done
    [Mon Jul 05 19:17:05 2010] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Mon Jul 05 19:17:05 2010] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
    [Mon Jul 05 19:17:05 2010] [notice] Apache/2.2.14 (Unix) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
    [Mon Jul 05 21:11:38 2010] [warn] [client 81.92.182.156] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed
    [Mon Jul 05 21:11:38 2010] [warn] [client 81.92.182.156] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed
    [Mon Jul 05 21:11:47 2010] [warn] [client 81.92.182.156] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed, referer: ***/
    [Mon Jul 05 21:11:47 2010] [warn] [client 81.92.182.156] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed, referer: ***/
    [Mon Jul 05 21:11:49 2010] [warn] [client 81.92.182.156] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed, referer: ***/bridge.cwsl
    [Mon Jul 05 21:11:49 2010] [warn] [client 81.92.182.156] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed, referer: ***/bridge.cwsl
    [Mon Jul 05 21:11:53 2010] [warn] [client 81.92.182.156] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed, referer: ***/harbor.cwsl
    [Mon Jul 05 21:11:53 2010] [warn] [client 81.92.182.156] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed, referer: ***/harbor.cwsl
    [Mon Jul 05 21:21:22 2010] [error] [client 66.249.65.197] script '/home/www/yh/wp-login.php' not found or unable to stat
    [Mon Jul 05 22:21:10 2010] [warn] [client 123.125.66.130] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed
    [Mon Jul 05 22:21:16 2010] [warn] [client 220.181.7.70] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed
    [Mon Jul 05 22:54:51 2010] [warn] [client 184.73.19.148] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed
    [Mon Jul 05 22:54:52 2010] [warn] [client 184.73.19.148] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed
    [Mon Jul 05 22:54:53 2010] [warn] [client 184.73.19.148] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed
    [Mon Jul 05 22:54:54 2010] [warn] [client 184.73.19.148] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed
    [Mon Jul 05 22:54:54 2010] [warn] [client 184.73.19.148] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed
    [Mon Jul 05 22:54:55 2010] [warn] [client 184.73.19.148] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed
    [Tue Jul 06 00:27:22 2010] [error] [client 95.168.178.82] File does not exist: /home/www/yh/tech/?p=762, referer: ***/tech/%3fp=762
    [Tue Jul 06 03:30:18 2010] [warn] [client 123.125.66.78] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed
    [Tue Jul 06 03:30:20 2010] [warn] [client 220.181.7.122] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed
    [Tue Jul 06 06:26:17 2010] [warn] [client 66.249.65.238] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed
    [Tue Jul 06 06:26:17 2010] [warn] [client 66.249.65.238] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed
    [Tue Jul 06 06:57:57 2010] [warn] [client 66.249.65.242] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed
    [Tue Jul 06 06:57:57 2010] [warn] [client 66.249.65.242] mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed
    [Tue Jul 06 07:26:19 2010] [warn] child process 5005 still did not exit, sending a SIGTERM
    [Tue Jul 06 07:26:19 2010] [warn] child process 4373 still did not exit, sending a SIGTERM
    [Tue Jul 06 07:26:19 2010] [warn] child process 5063 still did not exit, sending a SIGTERM
    [Tue Jul 06 07:26:19 2010] [warn] child process 5120 still did not exit, sending a SIGTERM
    [Tue Jul 06 07:26:19 2010] [warn] child process 5027 still did not exit, sending a SIGTERM
    [Tue Jul 06 07:26:19 2010] [warn] child process 5125 still did not exit, sending a SIGTERM
    [Tue Jul 06 07:26:19 2010] [warn] child process 5029 still did not exit, sending a SIGTERM
    [Tue Jul 06 07:26:19 2010] [warn] child process 5031 still did not exit, sending a SIGTERM
    [Tue Jul 06 07:26:21 2010] [warn] child process 5005 still did not exit, sending a SIGTERM
    [Tue Jul 06 07:26:21 2010] [warn] child process 4373 still did not exit, sending a SIGTERM
    [Tue Jul 06 07:26:21 2010] [warn] child process 5063 still did not exit, sending a SIGTERM
    [Tue Jul 06 07:26:21 2010] [warn] child process 5120 still did not exit, sending a SIGTERM
    [Tue Jul 06 07:26:21 2010] [warn] child process 5027 still did not exit, sending a SIGTERM
    [Tue Jul 06 07:26:21 2010] [warn] child process 5029 still did not exit, sending a SIGTERM
    [Tue Jul 06 07:26:21 2010] [warn] child process 5031 still did not exit, sending a SIGTERM
    [Tue Jul 06 07:26:23 2010] [warn] child process 5005 still did not exit, sending a SIGTERM
    [Tue Jul 06 07:26:23 2010] [warn] child process 4373 still did not exit, sending a SIGTERM
    [Tue Jul 06 07:26:23 2010] [warn] child process 5120 still did not exit, sending a SIGTERM
    [Tue Jul 06 07:26:23 2010] [warn] child process 5027 still did not exit, sending a SIGTERM
    [Tue Jul 06 07:26:23 2010] [warn] child process 5031 still did not exit, sending a SIGTERM
    [Tue Jul 06 07:26:25 2010] [error] child process 5005 still did not exit, sending a SIGKILL
    [Tue Jul 06 07:26:25 2010] [error] child process 4373 still did not exit, sending a SIGKILL
    [Tue Jul 06 07:26:25 2010] [error] child process 5027 still did not exit, sending a SIGKILL
    [Tue Jul 06 07:26:25 2010] [error] child process 5031 still did not exit, sending a SIGKILL
    [Tue Jul 06 07:26:26 2010] [notice] caught SIGTERM, shutting down

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •