Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
*Can anyone help me with a res problem? My monitor is capable of 1280 * 1024 but the GUI only lists 800*600 or lower. When I first fired up this ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! Qbit's Avatar
    Join Date
    May 2010
    Location
    Vancouver, Canada
    Posts
    11

    resolution problem


    *Can anyone help me with a res problem? My monitor is capable of 1280 * 1024 but the GUI only lists 800*600 or lower. When I first fired up this computer with the new install, (using a different monitor) it was displaying 1280 * 1024. When I shut down and started with this monitor is reverted to 800*600???. Is there a way to force a change to higher resolution.
    I am a complete newb with linux but fairly novice with computers in general.

  2. #2
    Linux Newbie lugoteehalt's Avatar
    Join Date
    Jan 2004
    Posts
    232
    X is meant to default to the highest resolution available.

    You could try ctrl+alt+keypad + to cycle through the resolutions, see what happens.

    Perhaps edit /etc/X11/xorg.conf to give higher resolution - search up a specimen xorg.conf file on the internet and use that as an exemplar.

    The log file /var/log/Xorg.0.log or something along those lines might give a clue.

    Perhaps try 'dpkg-reconfigure', with suitable flag or whatever it is called. If it's a Debian based system.
    Last edited by lugoteehalt; 06-26-2010 at 10:08 PM.
    All power is violence; all power is evil.
    Money As Debt

  3. #3
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi and Welcome !

    Which Graphics Card do you have? Set correct driver, Refresh Rates and Resolutions in xorg.conf file.

    I am posting generic xorg.conf file. It works fine with most of Monitors and Graphics Cards. Back up existing xorg.conf file and create new.
    Code:
    cd /etc/X11
    su -
    mv xorg.conf xorg.conf.bak
    nano xorg.conf
    Generic File :
    Code:
    Section "Device"
           Identifier "Configured Video Device"
           Driver    "vesa"  
    EndSection
    
    Section "Monitor"
             Identifier "Configured Monitor"
             HorizSync 31.5 - 70.0
             VertRefresh 50 - 160
     EndSection
    
    Section "Screen"
            Identifier "Default Screen"
            Monitor "Configured Monitor"
            Device "Configured Video Device"
            DefaultDepth 24
            Subsection "Display"
                 Depth 24
                 Modes "1280x1024" "1024x768" 
            EndSubsection
    EndSection
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  4. #4
    Just Joined! Qbit's Avatar
    Join Date
    May 2010
    Location
    Vancouver, Canada
    Posts
    11

    Thanks for the help

    Devils Casper
    Thanks for the response. I will try the new file once I figure out this file structure. I can't seem to find the file xorg file or folder. Can you give me a path (location on drive) to it? Also, what file editor would you recommend, assuming the xorg file will need to be modified?
    ps- when i said i was a newb, i really meant it!

    Qbit

  5. #5
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Check /etc/X11 folder. Its Capital X in X11.

    Rename existing xorg.conf file, if any and create new file.
    Code:
    cd /etc/X11
    mv xorg.conf xorg.conf_bak
    Use nano editor to create new file in command line
    Code:
    nano /etc/X11/xorg.conf
    Or
    An easier way, use Gedit. Press Alt+F2 and type this
    Code:
    gksu gedit /etc/X11/xorg.conf
    Above code will open an empty xorg.conf file in Gedit with root privileges.
    Copy contents from post #3. Save file and reboot machine.
    [code]
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #6
    Just Joined! Qbit's Avatar
    Join Date
    May 2010
    Location
    Vancouver, Canada
    Posts
    11
    I chose the Gedit method and rebooted after cutting and pasting the monitor code into it. Now I have "Out of Range" 68.7kHZ/85HZ error message on the screen after boot up.
    I tried a better quality monitor and also got "unusable signal", or something like that.
    Is there a simple was to go back to old setting so as to try another resolution?
    btw- my grapics card is a ASUS AGP-V3800 Ultra TNT2
    Monitor is an LG model L1734S-BN

  7. #7
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Press Alt+Ctrl+F3. Does machine switch to command line mode? If not, boot up in Single User Mode.
    Open /etc/X11/xorg.conf file and lower VertRefresh rates.
    Code:
    Section "Monitor"
             Identifier "Configured Monitor"
             HorizSync 31.5 - 70.0
             VertRefresh 50 - 100
     EndSection
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  8. #8
    Just Joined! Qbit's Avatar
    Join Date
    May 2010
    Location
    Vancouver, Canada
    Posts
    11
    got the command line to work- ran nano editor and found vert rate at 160 so changed it to 100. Now it says "permission denied" when trying to overwrite the file.
    suggestions?

  9. #9
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    You must have root permissions to edit xorg.conf file.
    Use sudo to gain root privileges.
    Code:
    sudo nano /etc/X11/xorg.conf
    It will ask for password. Type your own password. Nothing will appear on screen while typing password. Just type correct password and hit Enter key.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  10. #10
    Just Joined! Qbit's Avatar
    Join Date
    May 2010
    Location
    Vancouver, Canada
    Posts
    11
    apparently i am not in the sudoers file and the incident will be reported!

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •