Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
hello friends i just installed Debian 5.0.5 ! and i used guided partition (option one) while installing BUT immediately i cannot access my Windows drives C & D. if i ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! zeneknath's Avatar
    Join Date
    Feb 2010
    Posts
    42

    Post Invalid mount option


    hello friends

    i just installed Debian 5.0.5 ! and i used guided partition (option one) while installing BUT immediately i cannot access my Windows drives C & D. if i click it , it says "Invalid mount option when attempting to mount the volume C " how to fix it?
    Thanks in advance !

  2. #2
    Linux Engineer nujinini's Avatar
    Join Date
    Apr 2009
    Posts
    1,272
    Hello zeneknath!

    Please post the output of the following:

    fdisk -l (l is small L)
    df -h
    Last edited by nujinini; 07-11-2010 at 04:31 PM.
    nujinini
    Linux User #489667

  3. #3
    Just Joined!
    Join Date
    Mar 2010
    Posts
    79
    you need the package
    ntfs-3g

  4. #4
    Just Joined! zeneknath's Avatar
    Join Date
    Feb 2010
    Posts
    42

    Post output for fdisk-l

    hello nujinini !

    output for
    fdisk -l
    was this
    Disk /dev/sda: 320.0 GB, 320071851520 bytes
    255 heads, 63 sectors/track, 38913 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0xff45ff45

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 6533 52476291 7 HPFS/NTFS
    /dev/sda2 6534 29608 185349937+ 7 HPFS/NTFS
    /dev/sda3 29609 38583 72091687+ 83 Linux
    /dev/sda4 38584 38913 2650725 5 Extended
    /dev/sda5 38584 38913 2650693+ 82 Linux swap / Solaris


    and for
    df -h
    Filesystem Size Used Avail Use% Mounted on
    /dev/sda3 68G 3.1G 62G 5% /
    tmpfs 1.7G 0 1.7G 0% /lib/init/rw
    udev 10M 824K 9.2M 9% /dev
    tmpfs 1.7G 0 1.7G 0% /dev/shm

    i am ?...

  5. #5
    Linux Engineer nujinini's Avatar
    Join Date
    Apr 2009
    Posts
    1,272
    Your windows partition seems to be ok.

    /dev/sda1 * 1 6533 52476291 7 HPFS/NTFS
    /dev/sda2 6534 29608 185349937+ 7 HPFS/NTFS
    All we have to do I think is to mount them and make your Debian read the partitions. I encountered the same problem several months back and devils casper helped me solve it.

    Check this please.

    Feel free to post the outputs just in case you encounter problems.

    Best of luck!
    Last edited by nujinini; 07-12-2010 at 07:44 AM.
    nujinini
    Linux User #489667

  6. #6
    Just Joined! zeneknath's Avatar
    Join Date
    Feb 2010
    Posts
    42

    Post unknown file format

    hello friend..
    when i typed ...(as root....)
    mount /dev/sda1 /mnt
    mount point got vanished....
    and then...
    How ? to change/save (/dev/sda1 /media/sda1 ntfs-3g defaults,umask=0 0 0) in the file etc/fstab file using command's
    coz it's not saving directly with Graphical mode ....
    and...
    mkdir /media/sda1
    it created the sda1 but after
    mount -t ntfs-3g /dev/sda1 /media/sda1 -o defaults,umask=0
    it gave..error
    mount: unknown filesystem type 'ntfs-3g'

  7. #7
    Linux Engineer nujinini's Avatar
    Join Date
    Apr 2009
    Posts
    1,272
    Hi!

    Its ok. I think were getting closer. Every failure brings us closer to a solution

    You were able to successfully do mkdir /media/sda1.

    So now please execute this to get ntfs-3g

    Code:
    sudo apt-get install ntfs-3g
    Then afterwards you can now execute:

    Code:
    sudo mount -t ntfs-3g /dev/sda1 /media/sda1 -o defaults,umask=0
    Then if all goes well, we can now save the file in your /etc/fstab to make permanent. I use nano editor

    Code:
    sudo nano /etc/fstab
    Add the following line at the bottom

    Code:
    /dev/sda1 /media/sda1 ntfs-3g defaults,umask=0 0 0
    Save the file.
    nujinini
    Linux User #489667

  8. #8
    Just Joined! zeneknath's Avatar
    Join Date
    Feb 2010
    Posts
    42

    Post

    Thank you !
    din't had any problems.....
    all windows drivers got mounted....
    i can open it from COMPUTER.
    but all the drives are also seen on the Desktop(can it made to visible in the computer folder only?)
    no issues but just asking.....

    Thank's

  9. #9
    Linux Engineer nujinini's Avatar
    Join Date
    Apr 2009
    Posts
    1,272
    Congratulations!

    Glad to be of help!

    ...but all the drives are also seen on the Desktop(can it made to visible in the computer folder only?)
    Regarding the above, I'm not sure how to do it. I suggest you make another thread for it and we will hope that somebody who knows can give his idea.
    nujinini
    Linux User #489667

  10. #10
    Just Joined!
    Join Date
    Jul 2010
    Posts
    4
    Quote Originally Posted by zeneknath View Post
    but all the drives are also seen on the Desktop(can it made to visible in the computer folder only?)
    no issues but just asking.....

    Thank's
    If you don't want to see the mounted volumes/drives on your Desktop, I asume you are using gnome. Start a shell and type:

    Code:
    gconf-editor
    expand "apps" scroll down to nautilus and expand it and select "desktop" and then at the right hand, uncheck "volumes_visible" and you are done.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •