Find the answer to your Linux question:
Results 1 to 7 of 7
Hi, just changed from Ubuntu to Debain and for some reason I can't mount my library drive. It's having some sort of permission issues and I cant change them. I've ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2010
    Posts
    34

    Can't mount drive


    Hi, just changed from Ubuntu to Debain and for some reason I can't mount my library drive.
    It's having some sort of permission issues and I cant change them. I've tried the chown and chgrp commands but still no luck. My user name and group are exactly the same as they were in Ubuntu.
    If i right click the drive in computer and check the properties, it says owner: Unknown - Read Only group: Unknown - Read Only.

    It has alot of irreplacable data on it and I need to access it. can any one help??

  2. #2
    Just Joined!
    Join Date
    Mar 2010
    Posts
    34
    Ok I've chnged the fstab and instaed of saying that it can't mount due to permission it saying that its the wrong file system type. I know the drive is in ext4, can debain not read ext4 by default?? is there some thing i can do or download to get it to?

  3. #3
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    No, Debian Lenny does not yet support ext4.

    You can install a newer kernel with ext4 support from Debian Backports or you can switch to a distro with a newer kernel, including the testing version of Debian.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2010
    Posts
    34
    I've never played much with kernals and stuff, I've always let the distro manage its own updates etc.

    Is there any risk in manually installing a new kernal?

  6. #5
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    I wouldn't say it's "manually" installing, the package manager is still taking care of everything. There is always a little risk in changing kernels, being the, er, kernel of the system and all, so if something does go wrong and you can't boot into the system at all, it's more challenging to fix.

    It shouldn't remove the old kernel however, just give you another option in the GRUB boot menu, so you should have no trouble booting back into the old kernel if necessary. The risk is pretty small installing from backports, though.

  7. #6
    Just Joined!
    Join Date
    Mar 2010
    Posts
    34
    Hi there,
    Still having trouble with mounting drives, I have a usb pen drive that mounts no trouble now I've installed ntfs-3g and modified the fstab. however i can't write to it. I get the error as shown in the attached screen shot.

    my fstab entry for it is as follows;
    Code:
    UUID=D6B8CB35B8CB1343	/media/MyUSB30GB	ntfs	rw,user,defaults,umask=0	0	0
    is there someting i'm missing to make it writable?
    Attached Images Attached Images

  8. #7
    Just Joined!
    Join Date
    Jan 2009
    Posts
    1
    Quote Originally Posted by Jonny87 View Post
    Hi there,
    Still having trouble with mounting drives, I have a usb pen drive that mounts no trouble now I've installed ntfs-3g and modified the fstab. however i can't write to it. I get the error as shown in the attached screen shot.

    my fstab entry for it is as follows;
    Code:
    UUID=D6B8CB35B8CB1343	/media/MyUSB30GB	ntfs	rw,user,defaults,umask=0	0	0
    is there someting i'm missing to make it writable?
    Hi Jonny87

    I'm just getting back into Linux and was having this same problem with Debian Lenny 5.5 trying to mount my C drive that I have XP on, (my Linux is on D drive. And I came across a post in another forum with this fix and it works GREAT. If you already mat this will help some one else that is looking for an answer

    First you have to install Libfuse2 and ntfs-3g

    apt-get install libfuse2
    apt-get install ntfs-3

    Make sure the system see the the drive with fdisk -l | grep ntfs

    you should see something like:
    /dev/hda1 * 1 14387 156288421+ 7
    NPFH/NTFS

    This show that the drive is there make sure it isn't mounted

    mount

    you shouldn't see anything

    Now some of this it looks like you have already done
    so I'll use you set up

    mkdir /media/MyUSB30GB
    mount -t ntsf-3g /dev/hda1 /media/MyUSB30GB

    Modify the fstab with /dev/hda1 /media/MyUSB30GB

    This should mount you USB drive

    Now check the /media/MyUSB30GB folder and you should see your stuff and also there will be an icon on the desk top.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •