Find the answer to your Linux question:
Results 1 to 8 of 8
Just when I thought my hardware configuring woes were put to an end, I don't have any sound. Here is my lspci list. Code: debian:~# lspci | grep Audio 00:1b.0 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2007
    Posts
    52

    No sound


    Just when I thought my hardware configuring woes were put to an end, I don't have any sound. Here is my lspci list.

    Code:
    debian:~# lspci | grep Audio
    00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
    And the aplay -l

    Code:
    debian:~# aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: HDA Generic [HDA Generic]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    I've been googling for hours to find a solution and havn't found anything worth trying out. Does anyone know what is going on or what's not going on with my sound?

  2. #2
    Linux Newbie craigevil's Avatar
    Join Date
    Jun 2005
    Location
    Terra in the Milky Way
    Posts
    109
    go through the ALSA checklist:
    1) add yourself to the 'audio' group (log out and log in again)
    2) use alsamixer and unmute channels and raise levels (also try muting some channels & toggle jack sense)
    3) arts or esound stopped?
    4) OSS modules unloaded?
    5) speakers on?
    6) modprobe snd-pcm-oss
    7) does "aplay /usr/share/sounds/alsa/Noise.wav" work for root? Test your sound with aplay and a wav so codec issues don't confuse the situation.

    if none of that works try the following.

    The following string needs to be added to the /etc/modprobe.d/alsa-base.conf file

    options snd-hda-intel model=YOUR_MODEL

    Valid model names (that replace YOUR_MODEL) depending on the codec chip, can be found

    here and here.

    You can find your codec chip name using this command

    Code:
    cat /proc/asound/card*/codec* | grep Codec
    Each combination of audio codec, audio mixer and audio device name requires a very specific configuration in the alsa-base.conf file, if the audio chipset does not work out-of-the-box.

    To see if there is more than one alsactl executable in your path and remove the wrong/oldest one please copy&paste the following command into a Terminal and press the <enter> key:

    Code:
    sudo which alsactl
    or su if you do not have sudo setup.

    Having more than one alsactl can cause your sound settings to be muted during every boot.
    Debian Sid LXDE Kernel liquorix CPU Pentium IV 2.80GHz GeForce 9400 GT
    Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
    Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi

  3. #3
    Linux Newbie lugoteehalt's Avatar
    Join Date
    Jan 2004
    Posts
    232
    Thanks craigevil, that has to be the definitive answer to sound questions. I'm going to put it in my little box, shove it down the front of my slacks, and keep it there forever.
    All power is violence; all power is evil.
    Money As Debt

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Dec 2007
    Posts
    52
    Thanx for you taking the time to assist me in this headache. I've done what you asked down to the letter.

    I'll paste what I've seen.

    1) Use is already in audio group
    2) Used alsaconf and then alsamixer to un-mute, to no avail.

    Quote Originally Posted by craigevil
    3) arts or esound stopped?
    Huh??

    Quote Originally Posted by craigevil
    4) OSS modules unloaded?
    I'm not sure, how would I go about confirming that?

    5) This is the Dell Inspiron 1440 laptop so yes the speakers are on and working prior to me installing Debian Lenny.

    6) I ran the modprobe command.
    7) I ran the aplay /usr/share/sounds/alsa/Noise.wav as root. Nothing happened.

    I got the Codec chip name, what am I supposed to do with it next?

    Code:
    user@debian:~$ cat /proc/asound/card*/codec* | grep Codec
    Codec: IDT ID 7605
    I went to those web sites and pretty much got lost, any help on that is appreciated. I also ran this command as root:

    Code:
    Inferno:~# which alsactl
    /usr/sbin/alsactl
    It looks like only one source is trying to do the sound. Other than that I'm still soundless. Any ideas?

  6. #5
    Linux Newbie lugoteehalt's Avatar
    Join Date
    Jan 2004
    Posts
    232
    Quote Originally Posted by dellthinker View Post
    Thanx for you taking the time to assist me in this headache. I've done what you asked down to the letter.

    I'll paste what I've seen.

    1) Use is already in audio group
    2) Used alsaconf and then alsamixer to un-mute, to no avail.


    Huh??


    I'm not sure, how would I go about confirming that?

    5) This is the Dell Inspiron 1440 laptop so yes the speakers are on and working prior to me installing Debian Lenny.

    6) I ran the modprobe command.
    7) I ran the aplay /usr/share/sounds/alsa/Noise.wav as root. Nothing happened.

    I got the Codec chip name, what am I supposed to do with it next?

    Code:
    user@debian:~$ cat /proc/asound/card*/codec* | grep Codec
    Codec: IDT ID 7605
    I went to those web sites and pretty much got lost, any help on that is appreciated. I also ran this command as root:

    Code:
    Inferno:~# which alsactl
    /usr/sbin/alsactl
    It looks like only one source is trying to do the sound. Other than that I'm still soundless. Any ideas?
    As far as I know arts, the sound server, is only used with KDE, the desktop environment. It will switch itself off after a delay if it is not being used. You can run it with the command artsd, meaning the arts daemon. To check if it is running do ps -A|grep arts.

    Equally esound is the enlightenment sound server - this things are intended to let several things have access to the sound device at the same time: so you might be playing some music but the warning noise when you do something wrong will also happen through the music. Probable start esound with esd, at a guess.

    OSS modules - lsmod, list modules, will give a list of loaded modules.

    If you use KDE, artsdsp in front of commands, e.g. artsdsp mplayer filename, solves a multitude of problems.

    I have a running nightmare with sound, and I've been using Linux for years. Sound is always the bugger.

    I ran the aplay /usr/share/sounds/alsa/Noise.wav as root. Nothing happened.
    If KDE try putting artsdsp in front.

    Start alsamixer, use <tab> to select 'all'. Fiddle with everything in sight. Mute toggle with m. The other, sound source things, with <spacebar>. Fiddle wildly, see if something starts working.

    [QUOTE]It looks like only one source
    is trying to do the sound. Other than that I'm still soundless./QUOTE]So you do get some sound??
    All power is violence; all power is evil.
    Money As Debt

  7. #6
    Just Joined!
    Join Date
    Dec 2007
    Posts
    52
    A bit of an update. After playing around with this situation for some time I finally decided to test my ear buds and check to see if any sound was coming out of them and lo and behold I can hear. Except when I pull the ear buds out of the laptop nothing comes through the speakers _except_ the system beeps. For example when you press the Back or down arrows in a console, you hear the beeps come through the laptop speakers but nothing else. Does anyone have an opinion on what I am experiencing?

  8. #7
    Linux Newbie lugoteehalt's Avatar
    Join Date
    Jan 2004
    Posts
    232
    You mean sound comes out of earphone things but not loudspeakers, except system beeps?

    Problem with ear phone socket - isn't there a mechanical switch in it which switches off the loudspeakers?? Perhaps try roughly shoving in the plug repeatedly. Is the laptop switched to some sort of 'don't use loudspeaker' mode, perhaps look in the BIOS?? Is there some sort of relevant alsamixer, say, thing? Have you looked in the sound section of 'control panel' type thing, these can be counter intuitive and tricky.
    All power is violence; all power is evil.
    Money As Debt

  9. #8
    Just Joined!
    Join Date
    Dec 2007
    Posts
    52
    Indeed, I just check my BIOS settings, other than the change I made when I first got the laptop (this is a brand new Inspiron 1440 btw) by switching the AHCI to ATA so I could even install Debian, I've made no other changes. I'll play around with the settings. If I get a break through I'll report.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •