Find the answer to your Linux question:
Results 1 to 4 of 4
Ok, I'm posting the question because after searching and finding other similar threads I still can't seem to find an answer which works for my system. The drive is a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2010
    Posts
    30

    Trying to change drive permissions


    Ok, I'm posting the question because after searching and finding other similar threads I still can't seem to find an answer which works for my system.

    The drive is a WD MyPassport USB drive formatted with ext3 file system My intent is to use the drive to save a PartedImage backup of the IBM-LT hard drive image. So I need to be able to see it as a writable drive.

    I can change to the drive in the terminal and see my directory:

    IBM-LT: /home/ron# cd /media/disk
    IBM-LT: /media/disk# ls -l
    total 2
    drwxr-x-r-x 2 root root 4096 2010-08-16 13:25 ibmbackup
    drwx------ 2 root root 16384 2010-08-14 16:40 lost+found
    IBM-LT: /media/disk#

    The directory ibmbackup is one I created through the terminal with the mkdir command but it's even a read only file.

    Hope this is enough info to work from.

    Thanks

    Ron

  2. #2
    Just Joined!
    Join Date
    Jul 2010
    Posts
    30
    Nobody knows, nobody understands my question, or the question asked wasn't needed to be ask...

    Guessing option 3 because I got done what I was trying to do.

    But still it would be nice to know how to change the permissions when typical change paths aren't available.

    Ron

  3. #3
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    You must give ownership of /media/disk to Regular User.
    Execute id command as Regular User and note down User_id and Group_Id.

    Log in as root and execute this
    Code:
    chown -R /media/disk  user_id:group_id
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  4. #4
    Just Joined!
    Join Date
    Jul 2010
    Posts
    30
    Quote Originally Posted by devils casper View Post
    You must give ownership of /media/disk to Regular User.
    Execute id command as Regular User and note down User_id and Group_Id.

    Log in as root and execute this
    Code:
    chown -R /media/disk  user_id:group_id
    Thanks, I'll give this a try.

    Ron

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •