Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I decided to upgrade to Squeeze from Etch. Sorry, not upgrade, but moving from etch to squeeze. Clean new install. Format disks, re-partition...etc. All goes perfectly well, until I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2008
    Posts
    32

    [SOLVED] Squeeze won't find grub


    Hi,

    I decided to upgrade to Squeeze from Etch.

    Sorry, not upgrade, but moving from etch to squeeze.

    Clean new install.
    Format disks, re-partition...etc.

    All goes perfectly well, until I reboot into my newly installed Squeeze.

    After the messages from the bios motherboard, there is a black screen with a flashing cursor, and nothing else happens.
    Now it should have been the GRUB coming up and asking which system to boot into.
    But there is nothing at all on my screen.

    I thought I've done something wrong during install, so I formated the disks again, and re-installed squeeze again.
    Just paying close attention to every message, before I went further.

    And AGAIN, when rebooting into the system, there is nothing on the screen.

    Anybody encountered this and have a fix?

    Regards.

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Have you tried to press any key at startup?

    Boot up from LiveCD of any Linux distro and check if there is any grub.conf or menu.lst file in /boot/grub folder. Does even /boot/grub folder exist?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Oct 2008
    Posts
    32
    Thanks for reply

    1. Have you tried to press any key at startup?
    Yes = nothing happens.

    2. Does even /boot/grub folder exist?
    Probably YES. Because it does not complain of anything at the end of installation.
    It says Congratulations...bla...bla...bla...ready to reboot into your new system (or so).

    3. Boot up from LiveCD of any Linux distro and check if there is any grub.conf or menu.lst file in /boot/grub folder
    Unfortunately, I am using this machine at work, and have no time for playing too much.
    Jobs needs doing.
    So, after 2 unsuccessful attempts to install it, I had to install Lenny, so I can carry on with my job.

    But I would still like to install Squeeze when I got some time.
    Only I don't want to experiment with installing it.

    In the mean time, I have found that there is a bug.
    Something like my problem.
    #565639 - SunBlade 1000 installation report - boot fails after installation - Debian Bug report logs
    Only I could not understand the fix.
    I am not very experienced with Linux.
    And I can't understand what he did to fix it.

    can you have a look at it and translate it for me?

    Thanks.

  4. #4
    Just Joined!
    Join Date
    Jul 2010
    Posts
    14
    I had this problem back with lenny but I was installing to a removeable device. But anyway what I did is

    1. Try LILO (option is there with the boot disk)
    2. If it doesn't work, install GRUB manually (information can be found via google)

    Btw, you can also boot manually, that is, by setting the ROOT and BOOT manually. Again, google. If the machine has another operating system installed, the installing GRUB will go like a breeze.

    Cheers

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •