Find the answer to your Linux question:
Results 1 to 5 of 5
So, I installed AGAIN Squeeze And again boot fails Now it shows error 15 I tried booting into a LiveCD (ubuntu) to see what is happening But I can't open ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2008
    Posts
    32

    [SOLVED] squeeze won't boot


    So, I installed AGAIN Squeeze
    And again boot fails
    Now it shows error 15

    I tried booting into a LiveCD (ubuntu) to see what is happening
    But I can't open grub.cfg file (you're not the owner, it says)

    What do I do to boot into my new squeeze?

  2. #2
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    Below is an explanation of Grub Error 15:

    File not found
    This error is returned if the specified file name cannot be found, but everything else (like the disk/partition info) is OK.
    It is looking for a file which is not there or not where it should be. Some additional information would be helpful. Is Debian the only operating system you have on the computer? If not, what else do you have? I am not a Debian user so am not sure if it uses Grub2 or Grub Legacy.

    Can you use the Ubuntu CD to mount the Debian partition to check for files in /boot/grub directory?
    If you don't know how to do this, post back.
    The reason you can't open the grub.cfg file is you are not doing it as root. Use the command: sudo cat /boot/grub/grub.cfg to view it. I don't know if you will need a password for the Live CD and output you get from this command will just show the Ubuntu file.

  3. #3
    Linux Guru
    Join Date
    Jul 2008
    Posts
    4,205
    What do I do to boot into my new squeeze?
    You can look through the Grub2 guide in my signature I guess.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! jheaton5's Avatar
    Join Date
    Sep 2009
    Location
    Sharpsburg, GA, USA
    Posts
    21
    Squeeze does use Grub2. In the guide referenced by rokytnji, look for grub commands. You can manually boot the computer with the correct command and uuid information that you can get by using your live cd. Also, stating the obvious, look for error 15 in the guide.

  6. #5
    Just Joined!
    Join Date
    Oct 2008
    Posts
    32
    Finally I solved the mystery (or misery)!

    It took me 3 installs to figure out what's going on, and the 4th install to successfully install it.

    The problem:
    like I said, after a nice clean install Squeeze won't boot.

    The problem occurred because I used a USB flash drive to install it.
    Why?
    I have used a USB flash drive (in fact the same flash drive, different iso image), to install many other Ubuntu/Debian before, never had this problem.

    So my PC has a IDE hard drive.
    You all know this is seen as hda by the system.
    No longer so in Squeeze.
    Now it is sdX

    So, when I came to the partitioning step, while installing, I have seen the USB flash drive as sda, and my hard drive as sdb.
    At the end of installation, it asks you to install the grub in your first drive.
    And the stupid installer has seen my USB flash drive as the first hard drive.

    Clever people developing such misleading software.
    I tried to send a report bug or contact them.
    It's easier to contact my grandfather on the other world then these people!

    To solve the problem, I just unplugged the USB flash drive just before it got to the partitioning step.

    Now the installer has seen only one hard drive - sdb (yes b) - and installed everything nice on it.

    System working perfect. Apart from stupid evolution email.

    Thanks for helping.

    Regards.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •