Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
when I try to install cpp4.3 it says : cpp-4.3 depends on libc6 (>= 2.11); however version of libc6 on system is 2.7-18 when I try to install libc6 2.11.2-5_i386.deb ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2010
    Posts
    36

    [SOLVED] installing libc6 on debian 500-i386


    when I try to install cpp4.3 it says :
    cpp-4.3 depends on libc6 (>= 2.11); however
    version of libc6 on system is 2.7-18

    when I try to install libc6 2.11.2-5_i386.deb it says :
    installing libc6 would break locales, and
    deconfigoration is not permitted

    can someone help me fix my problem?
    Thanks in advance

  2. #2
    Just Joined!
    Join Date
    Sep 2010
    Posts
    36
    Can't anybody help me? I have searched google for hours to find a solution

  3. #3
    Just Joined! jdkaye's Avatar
    Join Date
    Aug 2010
    Location
    Gorizia, Italy
    Posts
    65
    Hi DF,
    Which Debian are you using? Lenny? Squeeze? Sid? and what kernel?
    ciao,
    jdk

  4. #4
    Just Joined!
    Join Date
    Sep 2010
    Posts
    36
    Quote Originally Posted by jdkaye View Post
    Hi DF,
    Which Debian are you using? Lenny? Squeeze? Sid? and what kernel?
    ciao,
    jdk
    Lenny
    I don't know what kernel but here is where I downloaded it
    thoughtpolice.co.uk/vmware/#debian5.0

    Thanks

  5. #5
    Just Joined! jdkaye's Avatar
    Join Date
    Aug 2010
    Location
    Gorizia, Italy
    Posts
    65
    Hi Droid,
    You can find out what kernel you're running by executing the following command on the command line:
    Code:
    uname -r
    Do you have a special reason for running Lenny? Normally that's useful for servers that are mission critical. For normal users, not responsible for 100's of clients, I think Squeeze (testing) would be a better choice. Don't let the name "testing" fool you. I'ts remarkably stable. If you're interested in changing, let us know. Otherwise there are solutions to your problem but you'll wind up with a mixed testing-stable system anyway. Might as well bite the bullet and go to Squeeze.

    That's just my opinion of course.
    ciao,
    jdk

  6. #6
    Just Joined!
    Join Date
    Sep 2010
    Posts
    36
    Quote Originally Posted by jdkaye View Post
    Hi Droid,
    You can find out what kernel you're running by executing the following command on the command line:
    Code:
    uname -r
    Do you have a special reason for running Lenny? Normally that's useful for servers that are mission critical. For normal users, not responsible for 100's of clients, I think Squeeze (testing) would be a better choice. Don't let the name "testing" fool you. I'ts remarkably stable. If you're interested in changing, let us know. Otherwise there are solutions to your problem but you'll wind up with a mixed testing-stable system anyway. Might as well bite the bullet and go to Squeeze.

    That's just my opinion of course.
    ciao,
    jdk
    the kernel is 2.6.26-1-686
    I don't have a special reason for running Lenny. It's just the first one I found from the package downloads, and my target is doing a school project, in which I will edit some of the debian's libraries and improve them (developers work).
    If you think I should change for Squeeze for my needs I will do so, but if it isn't nescercerry I would really like to know the solution to my problem.
    Thanks in advance jdk, and for the helpfull comments

  7. #7
    Just Joined! jdkaye's Avatar
    Join Date
    Aug 2010
    Location
    Gorizia, Italy
    Posts
    65
    Quote Originally Posted by DroidFighter View Post
    If you think I should change for Squeeze for my needs I will do so, but if it isn't nescercerry I would really like to know the solution to my problem.
    Thanks in advance jdk, and for the helpfull comments
    OK I found your problem. You're trying to install the wrong version of cpp4.3 and this is causing dependency issues. You want the LENNY version of cpp4.3 which requires the libc6 version that you have.
    libc6 (>= 2.7-1) [not alpha, ia64]
    GNU C Library: Shared libraries
    also a virtual package provided by libc6-udeb
    Here's the link to the package page. It looks like you may have screwed up your repos in the /etc/apt/sources.list file. You might want to check that out. Post the results if you have a problem. So just install the Lenny version of all these programs since you want to stick to Lenny and that should solve your problem.
    ciao,
    jdk

  8. #8
    Just Joined!
    Join Date
    Sep 2010
    Posts
    36
    thanks for the comment, I have been looking through it and I think its either the cpp 4.3 I installed was correct or the gcc I installed that required cpp 4:4.3.2-2 was incorrect. Hope you can help me because all those packages I have installed were installed in order to install a gcc into my linux in order to be able to compile and change the code of the libraries of my linux.

  9. #9
    Just Joined! jdkaye's Avatar
    Join Date
    Aug 2010
    Location
    Gorizia, Italy
    Posts
    65
    Quote Originally Posted by DroidFighter View Post
    thanks for the comment, I have been looking through it and I think its either the cpp 4.3 I installed was correct or the gcc I installed that required cpp 4:4.3.2-2 was incorrect. Hope you can help me because all those packages I have installed were installed in order to install a gcc into my linux in order to be able to compile and change the code of the libraries of my linux.
    It's not installing gcc that's the problem. It's the version of gcc that seems to be the problem. You installed a non-Lenny version. To verify this just check your installed version of gcc
    Code:
    aptitude show gcc
    versus the Lenny version of gcc shown in the link I included in my previous posting. To fix this situation (still assuming you want to stick to Lenny) just remove
    Code:
    sudo aptitude remove gcc
    and replace it with the lenny version. You haven't shown me what you've got in /etc/apt/sources.list so I can't help you on how to fix that if it's broken.
    ciao,
    jdk

  10. #10
    Just Joined!
    Join Date
    Sep 2010
    Posts
    36
    But I think that in my last post that gcc is for lenny
    at least I have found it here and it's in the Lenny section
    packages.debian.org/lenny/gcc

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •