Find the answer to your Linux question:
Results 1 to 3 of 3
Hello I have used this guide to install kernel in my linux cyberciti.biz/tips/compiling-linux-kernel-26.html stage 1 worked perfectly. Now at stage 2 when I write the command dir/ls in the tmp ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2010
    Posts
    36

    [SOLVED] Can not install linux kernel


    Hello
    I have used this guide to install kernel in my linux
    cyberciti.biz/tips/compiling-linux-kernel-26.html

    stage 1 worked perfectly.
    Now at stage 2 when I write the command dir/ls in the tmp directory I see the file:
    linux-2.6.26.tar.bz2 (2.6.26 is the version of my kernel)
    And now if I try to the tar function on my file and write it like this:
    Code:
    tar -xjvf linux-2.6.26.tar.bz2 -C /usr/src
    it gives me couple of errors like:
    tar: bzip2: can not exec: no such directory
    tar: error is unrecoverable: exiting now
    tar: child returned status 2
    tar: error exit delayed from previus errors

    What can I do to be able to tar my file?
    Thanks in advance

  2. #2
    Linux Engineer GNU-Fan's Avatar
    Join Date
    Mar 2008
    Posts
    935
    You must be in the same dir as the .bz2 file.
    Also make sure you have the bz2 package installed.
    Debian GNU/Linux -- You know you want it.

  3. #3
    Just Joined!
    Join Date
    Sep 2010
    Posts
    36
    I have install bzip2 package and it worked.
    Thanks, solved!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •