Find the answer to your Linux question:
Results 1 to 10 of 10
i am trying to be able to print from a laptop running Mandriva spring 2010 to my ubuntu 9.10 desktop that my printer is hooked up to with no luck. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2010
    Location
    Alberta Canada
    Posts
    31

    setting up network printer?


    i am trying to be able to print from a laptop running Mandriva spring 2010 to my ubuntu 9.10 desktop that my printer is hooked up to with no luck. i have looked for many house but nothing i find seems to make any sense or does not help in my situation

  2. #2
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    This page pretty much takes it step by step. Once you get the Ubuntu print server going, open your printer utility in Mandriva and have it seek network printers. If you set your print server up correctly, Mandriva should find it. What type printer are you using? Can you print to it from the Ubuntu machine?
    Linux Mint + IceWM Registered: #371367 New Members: click here

  3. #3
    Just Joined!
    Join Date
    Mar 2010
    Location
    Alberta Canada
    Posts
    31
    i have followed all the steps in the link you posted with no luck the printer i am useing is a PSC 1100 and yes i can print from my ubuntu machine but i cannot fimt the printer via system - administration - printers on my mandriva machine

  4. #4
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    In Ubuntu, when you open the print configuration utility, there is a check beside "Share Published printers connected to this system?" Has the print server been restarted after checking this if recently done?
    Code:
    sudo /etc/init.d/cupsys restart
    Linux Mint + IceWM Registered: #371367 New Members: click here

  5. #5
    Just Joined!
    Join Date
    Mar 2010
    Location
    Alberta Canada
    Posts
    31
    yes that has all been done already

  6. #6
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Can you post your cupsd.conf?
    Linux Mint + IceWM Registered: #371367 New Members: click here

  7. #7
    Just Joined!
    Join Date
    Mar 2010
    Location
    Alberta Canada
    Posts
    31
    how do i do that?

  8. #8
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    From the command line:
    Code:
    sudo gedit /etc/cups/cupsd.conf
    Copy what's there and post it here please. I want to see it since I also ran into the exact same problem when running 9.10. The utility said the server was available for the network yet, the actual file did not reflect that. I had to make some minor changes to mine to get it seen as a network printer for other machines inside the network.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  9. #9
    Just Joined!
    Join Date
    Mar 2010
    Location
    Alberta Canada
    Posts
    31
    Code:
    LogLevel warn
    MaxLogSize 0
    SystemGroup lpadmin
    # Allow remote access
    Port 631
    Listen /var/run/cups/cups.sock
    # Share local printers on the local network.
    Browsing On
    BrowseOrder allow,deny
    BrowseRemoteProtocols
    BrowseAddress @LOCAL
    BrowseLocalProtocols CUPS dnssd
    DefaultAuthType Basic
    <Location />
      # Allow shared printing...
      Order allow,deny
      Allow @LOCAL
    </Location>
    <Location /admin>
      # Restrict access to the admin pages...
      Order allow,deny
    </Location>
    <Location /admin/conf>
      AuthType Default
      Require user @SYSTEM
      # Restrict access to the configuration files...
      Order allow,deny
    </Location>
    <Policy default>
      <Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job CUPS-Move-Job CUPS-Get-Document>
        Require user @OWNER @SYSTEM
        Order deny,allow
      </Limit>
      <Limit CUPS-Add-Modify-Printer CUPS-Delete-Printer CUPS-Add-Modify-Class CUPS-Delete-Class CUPS-Set-Default CUPS-Get-Devices>
        AuthType Default
        Require user @SYSTEM
        Order deny,allow
      </Limit>
      <Limit Pause-Printer Resume-Printer Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer Activate-Printer Restart-Printer Shutdown-Printer Startup-Printer Promote-Job Schedule-Job-After CUPS-Accept-Jobs CUPS-Reject-Jobs>
        AuthType Default
        Require user @SYSTEM
        Order deny,allow
      </Limit>
      <Limit CUPS-Authenticate-Job>
        Require user @OWNER @SYSTEM
        Order deny,allow
      </Limit>
      <Limit All>
        Order deny,allow
      </Limit>
      # Only the owner or an administrator can cancel a job...
      <Limit Cancel-Job>
        Order deny,allow
        Require user @OWNER @SYSTEM
      </Limit>
    </Policy>
    <Policy authenticated>
      <Limit Create-Job Print-Job Print-URI>
      AuthType Default
      Order deny,allow
    </Limit>
      <Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job CUPS-Move-Job CUPS-Get-Document>
    AuthType Default
    Require user @OWNER @SYSTEM
    Order deny,allow
      </Limit>
      <Limit CUPS-Add-Modify-Printer CUPS-Delete-Printer CUPS-Add-Modify-Class CUPS-Delete-Class CUPS-Set-Default>
      AuthType Default
      Require user @SYSTEM
      Order deny,allow
        </Limit>
      <Limit Pause-Printer Resume-Printer Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer Activate-Printer Restart-Printer Shutdown-Printer Startup-Printer Promote-Job Schedule-Job-After CUPS-Accept-Jobs CUPS-Reject-Jobs>
        AuthType Default
        Require user @SYSTEM
        Order deny,allow
          </Limit>
      <Limit Cancel-Job CUPS-Authenticate-Job>
          AuthType Default
          Require user @OWNER @SYSTEM
          Order deny,allow
            </Limit>
      <Limit All>
            Order deny,allow
              </Limit>
    </Policy>


    is from my ubuntu 9.10 machine which has the printer connected via USB

  10. #10
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    My printer is accessible from all computers within my cups network. This is what I have in the corresponding places in yours.
    Code:
    # Enable printer sharing and shared printers.
    Browsing On
    BrowseOrder allow,deny
    BrowseAllow all
    BrowseAddress @LOCAL
    BrowseAddress 192.168.1.*
    DefaultAuthType Basic
    <Location />
      # Allow shared printing...
      Order allow,deny
      Allow all
      Allow @LOCAL
      Allow 192.168.1.*
    </Location>
    Finding the ip address of your network is easily discernible by doing from the command line:
    Code:
    ifconfig
    If your network runs IPs from say... 192.168.1.101 through 192.168.1.150 then you'd set your cups.conf just like what I have above. The thing is to add that "*" where the last set of numbers would be in the IP. If you want just the lappy to have print access, find its IP address and use it alone. Example: Lappy is 192.168.1.104:
    Code:
    # Enable printer sharing and shared printers.
    Browsing On
    BrowseOrder allow,deny
    BrowseAllow all
    BrowseAddress @LOCAL
    BrowseAddress 192.168.1.4
    DefaultAuthType Basic
    <Location />
      # Allow shared printing...
      Order allow,deny
      Allow all
      Allow @LOCAL
      Allow 192.168.1.4
    </Location>
    I had the same problem and this fixed it for me. Not sure where I found it but give it a try. Remember to restart cups. Hope this helps...
    Linux Mint + IceWM Registered: #371367 New Members: click here

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •