Find the answer to your Linux question:
Results 1 to 6 of 6
Hi all.. Im trying to set the following configuration on my debian5.0 machine. Code: address 172.27.111.27 netmask 255.255.255.248 gateway 172.28.112.41 But, it gives the follows when i restart the network. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2009
    Posts
    8

    Help to set IP. 'SIOCADDRT: No such process .'


    Hi all..

    Im trying to set the following configuration on my debian5.0 machine.
    Code:
    address 172.27.111.27
    netmask 255.255.255.248
    gateway 172.28.112.41
    But, it gives the follows when i restart the network.
    Code:
    Reconfiguring network interfaces...SIOCDELRT: No such process
    SIOCADDRT: No such process
    Failed to bring up eth0.
    done.
    Is their any issue related to netmask configuration?
    Help me to solve this.

  2. #2
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    I'm not sure if the netmask is right, looks like a /29 network, you sure this is right? usually home network is 255.255.255.0

    in either case, looks like something is configured incorrectly, post entire contents of /etc/network/interfaces file

    also post output of lspci -vnn and lsmod in CODE TAGS

  3. #3
    Just Joined!
    Join Date
    Nov 2009
    Posts
    8
    Yes, you are right. It's /29 network. I have to configure this set only.

    My /etc/network/interfaces content is
    Code:
    auto eth0
    iface eth0 inet static
    address 172.27.111.27
    netmask 255.255.255.248
    gateway 172.28.112.41
    Output of lspci -vnn is contains following ethernet controller data
    Code:
    01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 01)
    	Subsystem: Hewlett-Packard Company Device [103c:2a78]
    	Flags: bus master, fast devsel, latency 0, IRQ 222
    	I/O ports at de00 [size=256]
    	Memory at fdbff000 (64-bit, non-prefetchable) [size=4K]
    	[virtual] Expansion ROM at fdc00000 [disabled] [size=128K]
    	Capabilities: [40] Power Management version 2
    	Capabilities: [48] Vital Product Data <?>
    	Capabilities: [50] Message Signalled Interrupts: Mask- 64bit+ Queue=0/1 Enable+
    	Capabilities: [60] Express Endpoint, MSI 00
    	Capabilities: [84] Vendor Specific Information <?>
    	Capabilities: [100] Advanced Error Reporting <?>
    	Capabilities: [12c] Virtual Channel <?>
    	Capabilities: [148] Device Serial Number 00-e0-4c-36-00-00-00-05
    	Capabilities: [154] Power Budgeting <?>
    	Kernel driver in use: r8169
    	Kernel modules: r8169
    Then, the output of lsmod is attached as lsmod.txt

    thanks
    Attached Files Attached Files

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    this configuration isn't right, if you are using a /29 network, that means you only get 32 IP's

    that gateway is not inside the network of your IP, it has to be something reachable within the subnet, where are you getting your network configuration information from?

  6. #5
    Just Joined!
    Join Date
    Nov 2009
    Posts
    8
    the configuration is given by one of the authorized switch center to connect my software as client.

    Can you people please explain or refer any link to understand what is wrong with this configuration?

  7. #6
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    172.27.111.27 and 172.28.112.41 are not even close to being in the same network with the subnet mask you are using, the gateway address must be within 32 IPs of the network address you have in order to be reachable based on your subnet mask

    i would double check the configuration with who gave it to you

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •