Find the answer to your Linux question:
Results 1 to 4 of 4
i've read so many threads and pages regarding this problem, I dont even know if I've having the same issue as when I started. But I am going to start ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Posts
    9

    mount perimissions on external HD


    i've read so many threads and pages regarding this problem, I dont even know if I've having the same issue as when I started. But I am going to start over from the beginning and ask for help this time.

    I have a debian machine with an external harddrive. I have a windows machine on the same network from which I can read the files from the debian drive, but I cant write to it.
    At some point in time (several months ago?) I could.

    currently, I have this line in my /etc/fstab:
    /dev/sdb1 /media/MUSIC/ vfat user,uid=1000,gid=1000,rw,umask=000 0 0

    and i've tried a hundred different mount commands (but not as many as i've tried fstab lines) but generally have been using this at start up:
    sudo mount /dev/sdb1 /media/MUSIC/
    (i am under the impression that i should not have to use 'sudo' when doing this, since the fstab line includes 'user' but if i dont, the command fails)

    no matter what I've tried, the permissions come out as owned by root:
    drwxr-xr-x 905 root root 163840 2010-10-17 17:45 Music

    attempting (as root) to change ownership of the directory also does not work:
    chown: changing ownership of `/media/MUSIC/': Operation not permitted
    (because its a FAT file system, i think)

    i've confirmed that i have the uid and gid number correct with
    id sirka


    Could someone please help me?

    Thank you very much for your time
    Last edited by sirka; 11-13-2010 at 09:38 PM.

  2. #2
    Just Joined! barriehie's Avatar
    Join Date
    Apr 2008
    Location
    The Desert!
    Posts
    85
    Have you tried changing the directory permissions before mounting the drive?

  3. #3
    Just Joined!
    Join Date
    Jan 2007
    Posts
    9
    i did and it produced what seemed like weird results to me.
    after rebooting, i switched to root user and did:
    chown sirka /media/MUSIC

    then i did
    ls -l /media

    and it showed sirka has the group and owner.
    then i exited back to regular user sirka and mounted the drive (it failed and tried again using sudo, and it worked).
    then i immediately did ls -l /media again
    and the owner and group was root.

    i guess this has something to with the drive being vfat? but really i am in no place to making guesses at this point.

    ETA:
    i just repeated that process, except for the rebooting.
    i changed to root, umounted the drive, changed the permissions of the folder, checked with ls, changed to a normal user, attempted to mount the drive... and it worked. a regular user can now mount the drive.
    but then i did 'ls -l /media' and it is owned by root. i also tried to copy a file to the drive from a windows7 machine and still got a permissions error.
    Last edited by sirka; 11-13-2010 at 10:05 PM.

  4. #4
    Just Joined! barriehie's Avatar
    Join Date
    Apr 2008
    Location
    The Desert!
    Posts
    85
    Have you checked the drive for errors?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •