Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    [SOLVED] Error using dm-crypt with luks


    Hi guys,

    I'm quite new to Linux, but I hope I can give you all the information you need.
    I'll just post what I did, so this might be self explaining already

    server:~# apt-get install cryptsetup hashalot
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following extra packages will be installed:
    dmsetup
    Suggested packages:
    dosfstools
    The following NEW packages will be installed
    cryptsetup dmsetup hashalot
    0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
    Need to get 356kB of archives.
    After this operation, 975kB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Get: 1 ht tp://ftp.uk.debian.org lenny/main dmsetup 2:1.02.27-4 [37.8kB]
    Get: 2 ht tp://ftp.uk.debian.org lenny/main cryptsetup 2:1.0.6-7 [302kB]
    Get: 3 ht tp://ftp.uk.debian.org lenny/main hashalot 0.3-5 [16.0kB]
    Fetched 356kB in 0s (2992kB/s)
    Selecting previously deselected package dmsetup.
    (Reading database ... 19460 files and directories currently installed.)
    Unpacking dmsetup (from .../dmsetup_2%3a1.02.27-4_i386.deb) ...
    Selecting previously deselected package cryptsetup.
    Unpacking cryptsetup (from .../cryptsetup_2%3a1.0.6-7_i386.deb) ...
    Selecting previously deselected package hashalot.
    Unpacking hashalot (from .../hashalot_0.3-5_i386.deb) ...
    Processing triggers for man-db ...
    Setting up dmsetup (2:1.02.27-4) ...
    Setting up cryptsetup (2:1.0.6-7) ...
    update-initramfs: deferring update (trigger activated)
    Setting up hashalot (0.3-5) ...
    Processing triggers for initramfs-tools ...
    update-initramfs: Generating /boot/initrd.img-2.6.26-2-686
    server:~#
    server:~#
    server:~# dd if=/dev/zero of=/logcontainer bs=1M count=1000
    1000+0 records in
    1000+0 records out
    1048576000 bytes (1.0 GB) copied, 17.0031 s, 61.7 MB/s
    server:~#
    server:~#
    server:~# losetup /dev/loop0 /logcontainer
    server:~# cryptsetup luksFormat /dev/loop0

    WARNING!
    ========
    This will overwrite data on /dev/loop0 irrevocably.

    Are you sure? (Type uppercase yes): YES
    Enter LUKS passphrase:
    Verify passphrase:
    Command failed: Failed to setup dm-crypt key mapping.
    Check kernel for support for the aes-cbc-essiv:sha256 cipher spec and verify that /dev/loop0 contains at least 133 sectors

    server:~#
    server:~#
    server:~# modprobe aes
    WARNING: Error inserting padlock_aes (/lib/modules/2.6.26-2-686/kernel/drivers/crypto/padlock-aes.ko): No such device
    I'm trying to get rid of this error for a couple of days now but without luck...
    I even reinstalled the system, but it's always exactly the same.

    Thanks a lot in advance!
    Last edited by FakeAccount; 12-03-2010 at 04:10 PM.

  2. #2
    had to do a "modprobe dm-mod" first, now it works

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •