Find the answer to your Linux question:
Results 1 to 4 of 4
hello all, i'm using an arm target, with busybox. i have a problem with system time. the 'date' returns: mon aug 13 18:11:21 utc 1923 !!!!!! 1923!!!!! !!! date +%s ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2010
    Posts
    4

    [SOLVED] negative linux time


    hello all,

    i'm using an arm target, with busybox.

    i have a problem with system time.

    the 'date' returns: mon aug 13 18:11:21 utc 1923 !!!!!!

    1923!!!!!
    !!!

    date +%s returns -1463809525 , a negative time!

    very bizzare specially time_t should be unsigned int i think,

    the weirdest thing is that even after power down the target it returns to 1923.

    any suggestions?
    Last edited by liora002; 12-13-2010 at 03:00 PM.

  2. #2
    Linux User Manko10's Avatar
    Join Date
    Sep 2010
    Posts
    250
    Sync your clock via NTP and write the current time to your hardware clock with hwclock -w
    If your clock is still resetted after rebooting, you should replace your CMOS battery as it seems to be empty.
    Refining Linux Advent calendar: 24 Outstanding ZSH Gems

  3. #3
    Just Joined!
    Join Date
    Dec 2010
    Posts
    4
    thanks , but this answer is good for PC.

    i'm using embedded hardware with ARM core.

    i dont have CMOS battery.

    can it be a bug in the bootloader?

    does the bootloader has any affect on linux system clock?

    can the bootloader config the linux system clock?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Dec 2010
    Posts
    4
    well the problem has been solved.

    it was an hardware problem, the rtc clock power in the cpu

    got the power before all cpu power returned from reset.

    this cause the RTC going wild to 2058, since i use 32 bit .... 1923.

    thanks for all

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •