Find the answer to your Linux question:
Results 1 to 9 of 9
hello everybody i currently have debian sid 2.2.20. i tried to install debian kernel 2.6.9 so i did all that is written here : http://www.desktop-linux.net/debkernel.htm but after reboot i have ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Posts
    5

    debian kernel 2.6.9


    hello everybody

    i currently have debian sid 2.2.20.
    i tried to install debian kernel 2.6.9 so i did all that is written here : http://www.desktop-linux.net/debkernel.htm

    but after reboot i have an error :

    VFS: cannot open root device "hda2" or unknown-block(0,0)
    Please append a correct "root=" boot option
    Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
    i'm using Grub and my kernel 2.2.20 works fine .. can you help me please

    thx (sry for my bad english )

  2. #2
    Linux User
    Join Date
    Sep 2003
    Posts
    254
    Hello
    Could u give us ur /boot/menu/grub.lst?
    Thx to that it will be more easy to see what's going on wrong

  3. #3
    Just Joined!
    Join Date
    Nov 2004
    Posts
    5
    this is my 'menu.lst'

    Code:
    title           Debian GNU/Linux, kernel 2.6.9
    root (hd0,0)
    kernel /boot/vmlinuz-2.6.9
    initrd /boot/initrd.img
    savedefault
    boot 
    
    title           Debian GNU/Linux, kernel 2.2.20-idepci
    root (hd0,0)
    kernel /boot/vmlinuz-2.2.20-idepci
    savedefault
    boot
    i created '.img' with the command 'make-kpkg --revision=<number> --initrd kernel-image'

    thx for your help

  4. $spacer_open
    $spacer_close
  5. #4
    er
    er is offline
    Just Joined!
    Join Date
    Jun 2004
    Location
    Scotland
    Posts
    6
    hmm 2.2.20 is debian's defalt kernel, reinstall ?

    cd in to src

    download the kernel source FTP or WGET

    tar zxvf linux-2.6.9.tar.gz

    cd linux

    make menuconfig

    add the packets that you need

    make dep ; make clean

    make bzImage

    make modules

    make modules_install

    copy the kernel to the boot dir

    cp /usr/src/linux/arch/i386/boot/bxImage /boot

    make a lilo backup of lilo.conf

    cp /etc/lilo.conf /etc/lilo.conf.bak

    so it points to the new kernel

    /sbin/lilo

    Make mrproper

    And reboot
    and enjoy
    :P , if it's what you where needing

  6. #5
    Just Joined!
    Join Date
    Nov 2004
    Posts
    5
    ok i will try it tomorrow

    i'm off .. i spent all my WE to try to resolve my problem :s


    good night

  7. #6
    Linux Newbie
    Join Date
    Jul 2004
    Location
    WA, USA
    Posts
    102
    You need to build your filesystem support INTO the kernel, not as a module. (Check instead of an asterisk.) You can do this by reconfiguring and remaking your kernel using the instruction set you already found. It should be under 'filesystems' or something similiar.

    Robert Peaslee
    Taking a walk on the wonderful path computers have lain before me

  8. #7
    Linux Newbie
    Join Date
    Oct 2004
    Location
    Manchester, England
    Posts
    165
    you also want a root=/dev/hd(x) on kernel line

  9. #8
    Just Joined!
    Join Date
    Nov 2004
    Posts
    5
    Quote Originally Posted by PeasleeR
    You need to build your filesystem support INTO the kernel, not as a module.
    i did that ... i tried to check EXt3 only then EXT2 and EXT3 but always the same pb

    i used the .config from alexis de lattre with some modifications (but no change in 'file systems') but that doesn't work too.

  10. #9
    Just Joined!
    Join Date
    Nov 2004
    Posts
    5
    yessss i'm now under sid 2.6.9 with kde3.3

    i resolved all my problems. i started from sarge2.4.17 then upgrade to 2.6.9

    yeah

    thx for your help good night

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •