Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 13 of 13
Originally Posted by glaston Is it giving you display mode options? It might be defaulting to a safe display mode due to the monitor change. Linux can be finicky. Even ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Newbie
    Join Date
    May 2010
    Posts
    125

    Quote Originally Posted by glaston View Post
    Is it giving you display mode options?

    It might be defaulting to a safe display mode due to the monitor change.
    Linux can be finicky. Even Debian.
    As a long shot you could try plugging the old monitor back in.

    Or install KDE using apt. If you don't like it just install gnome and use GDM instead of KDM as the default.
    No basically I have to command "startx" to get into GDM at all, and no options are presented; Debian just starts up in command line environment and that's that.

    Quote Originally Posted by glaston View Post
    Is it giving you display mode options?

    It might be defaulting to a safe display mode due to the monitor change.
    Linux can be finicky. Even Debian.
    As a long shot you could try plugging the old monitor back in.

    Or install KDE using apt. If you don't like it just install gnome and use GDM instead of KDM as the default.
    No, plugging back in the old monitor does not work I'm afraid.

    I wish I understood Debian's display manager behaviour better; it's just downright annoying and inconvenient. Due to this and other problems, I was forced to do a clean install. It remains to be seen if problems emerge when I alternate once again between monitors. The thing is they are exactly the same model monitor, which makes it even harder to see why this problem crops up.

    I want to thank everyone who has tried to help. Sometimes you just don't have time to be messing around. Linux could be better in this regard; I've never had problems installing and setting up Windows before, but Linux and Debian in particular always poses such a challenge.

    I have a personal attachment to Debian, and I've persevered precisely because of that. I just wish it were easier.

  2. #12
    Just Joined!
    Join Date
    Sep 2008
    Posts
    73
    No basically I have to command "startx" to get into GDM at all, and no options are presented; Debian just starts up in command line environment and that's that.
    What I meant by "display mode" was "console resolution".
    GDM starts pretty much right after the system enters runlevel-2, so the "invalid table" error might not be related to the gdm issue at all.
    Did you select "desktop environment" during the initial install?
    I know you did a clean install so your problem has been taken care of.
    I'm just thinking that there should've been an easier way, and for others encountering the problem a clean install might not be an option.
    So this thread isn't solved yet.

  3. #13
    Linux Newbie
    Join Date
    Sep 2007
    Posts
    218
    I have to command "startx" to get into GDM
    Possible option...

    Code:
    # update-alternatives --config x-session-manager
    Select gdm as default session manager, quit X, then log out. The graphic login prompt should autostart.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •