Find the answer to your Linux question:
Results 1 to 7 of 7
I have a Logitech G330 USB headset, but all I get is the microphone looped back into the headphones. arecord doesn't pick up anything, and I'm not getting sound from ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2007
    Posts
    22

    [SOLVED] USB headset


    I have a Logitech G330 USB headset, but all I get is the microphone looped back into the headphones. arecord doesn't pick up anything, and I'm not getting sound from other sources (VLC).

    I've seen plenty of similar threads ask for the output of lsusb, so here's the relevant line from mine:

    Bus 002 Device 004: ID 046d:0a17 Logitech, Inc. G330 Headset

  2. #2
    Linux Newbie
    Join Date
    Sep 2007
    Posts
    218
    Do you have a GUI mixer installed, like alsamixergui?

  3. #3
    Just Joined!
    Join Date
    Apr 2007
    Posts
    22

    KMix

    KMix.
    "Right-click>>Select Master Channel>>Logitech G330 Headset" doesn't do anything.

    I've installed alsamixergui now, as well. It is defaulting to the system card.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2007
    Posts
    22
    Some more Googling prompted me to add "options snd-hda-intel index=-2" to the end of my /etc/modprobe.d/alsa-base.conf file. The headset works properly but at the expense of my system sound, even when the headset is unplugged.

  6. #5
    Just Joined!
    Join Date
    Apr 2007
    Posts
    22
    More fiddling: removed the index=-2 entry (had previously removed a similar entry for snd-usb-audio) and moved the headset to the top of the output devices listed in (KDE) System Settings>>Multimedia. Now, if the headset was plugged in at boot it will be the default sound device (but it will not revert to system sound if the headset is removed). If the headset was not plugged in at boot, it will use the onboard sound but will not switch to the headset if I plug it in.

    VLC will output sound to whichever device I specify in the preferences, even if that device is not the current default.

  7. #6
    Linux Newbie
    Join Date
    Sep 2007
    Posts
    218
    My mistake. Gonna bow out; maybe someone else can pick it up from here.

  8. #7
    Just Joined!
    Join Date
    Apr 2007
    Posts
    22
    Bleh. After 15+ hours of playing with ALSA and OSS4 config files/mixers, I have my solution:

    Install PulseAudio (and ALSA, if it wasn't already), reboot, then prioritize the headset in KDE's multimedia settings.
    I'm running Debian sid with what looks like KDE 4.4.3 (really? 4.6 is out and they haven't moved 4.5 into unstable yet?</rant>). It is my understanding that KDE's Pulseaudio support was implemented in 4.5 and patches were backported to 4.4, which means this may not work for those of you running 4.3 (or 4.4 on a distro that isn't derived from Debian).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •