Find the answer to your Linux question:
Results 1 to 5 of 5
Hallo all, I have installed a Knoppix3.6 (the hardware recognition was great) and then I installed in HD. I am trying to update packages und recompile kernel so I can ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Posts
    2

    Upgrade error


    Hallo all,
    I have installed a Knoppix3.6 (the hardware recognition was great) and then I installed in HD.
    I am trying to update packages und recompile kernel so I can test some experimental software that need for example the latest version of autoconf and automake..
    I am not an expert at all ... but I was reading for a long time the online manuals, and so on....

    I wrote my source.list with entries for stable un testing..
    and I did also
    Code:
     apt-get update
    without errors.
    I was trying with
    Code:
     dselect
    But I left everything per default...
    Then I did
    Code:
    apt-get upgrade
    and I got this error and I can't go on installing anything else since then...
    Code:
    root@ksat77:/etc/apt# apt-get upgrade 
    Reading Package Lists... Done
    Building Dependency Tree... Done
    You might want to run apt-get -f install' to correct these.
    The following packages have unmet dependencies:
      frozen-bubble: Depends: frozen-bubble-data (= 1.0.0-6) but 1.0.0-4 is installed
      testdisk: Depends: libntfs5 (>= 1.9.2) but it is not installed
    E: Unmet dependencies. Try using -f.
    root@ksat77:/etc/apt#
    I have already tried the comand subjected in the error output:

    Code:
     root@ksat77:/etc/apt# apt-get -f install 
    Reading Package Lists... Done
    Building Dependency Tree... Done
    Correcting dependencies... failed.
    The following packages have unmet dependencies:
      frozen-bubble: Depends: frozen-bubble-data (= 1.0.0-6) but 1.0.0-4 is installed
      testdisk: Depends: libntfs5 (>= 1.9.2) but it is not installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    E: Unable to correct dependencies
    root@ksat77:/etc/apt#
    I am in a point where I don't know what else can I do...
    I also don't know if the problem could come from the installation from Knoppix (based,but not debian..) Or if it is just a package that I have to uninstall....

    This is my /etc/apt/apt.conf
    Code:
    APT::Default-Release "testing";
    APT::Cache-Limit 10000000;
    Apt::Get::Purge;
    It is not important for me if I have a stable or testing system,but I would needed in any case the last version of some version and because of that I use testing...

    Any suggestion it will be very appreciate!
    Thank you in advance!
    igvargas

  2. #2
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    it is because it is not debian, but knoppix. Although, it may not be impossible, I have a feeling, that if you try to fix something that is broken, you will end up breaking something else.

    any reason why you can't install debian?

  3. #3
    Just Joined!
    Join Date
    Nov 2004
    Posts
    2
    First of all, Thank you for answering!
    I started with knoppix because for the first time it has a easier detection of hardware...I tried it and everything was recognized for the first time...so I didn't try with a "pure debian",that at the beginnin is harder to configure...
    It is clear for me that upgrade and other things maybe are not so good idea with knoppix..
    Regards,
    igvargas

    PS: I had already done a lot of searchs before posting...but later I have found an answer in another specific forum.
    I will copy the link just in case somebody come here with the same problem I have had.For me was helffull
    http://www.knoppix.net/forum/viewtopic.php?t=14516

  4. #4
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    you still may try debian, in most cases you will be fine. the only problem I had was a video card issue, but it wasn't to hard to fix. Also, you can many times use knoppix as a "guide" to making debian work correctly

  5. #5
    Linux Newbie
    Join Date
    Oct 2004
    Location
    Manchester, England
    Posts
    165
    If you are having hardware problems installing Debian, make sure you use the 2.4 kernel instead of the default 2.2.
    Have a look at the install help options on boot up screen, I think you need to type bf24 or similar to start with 2.4 kernel. This will help a lot with later hardware.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •