Find the answer to your Linux question:
Results 1 to 3 of 3
I'm having trouble with my Debian system (kernel 2.6.6, unstable) displaying Japanese correctly. On all of my programs in X, I can get Japanese to display correctly EXCEPT the kanji ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Posts
    4

    Japanese Kanji not displaying


    I'm having trouble with my Debian system (kernel 2.6.6, unstable) displaying Japanese correctly. On all of my programs in X, I can get Japanese to display correctly EXCEPT the kanji do not display correctly. Instead, it shows some hex code box, like a box with the value of the character displayed at each of the four corners:

    Code:
     ____
    |3  4|
    |2  3|
     ~~~~

    I've checked my fonts, and I can see all the kanji in all of my Japanese fonts thru xfontsel. What on earth could be the problem?

  2. #2
    Just Joined!
    Join Date
    Nov 2004
    Location
    New York
    Posts
    7
    same here,

  3. #3
    Just Joined!
    Join Date
    Oct 2004
    Posts
    4
    SOLVED.

    The problem lied with defoma; I guess that's what I get for using unstable. The Japanese fonts were not registered with defoma and therefore not used. Installing a ttf Japanese font package that had the necessary defoma registration did the trick wonderfully.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •