Find the answer to your Linux question:
Results 1 to 4 of 4
Hi i've configured my shell to export a PATH including java, and if i log in from console, typing "set" i can see PATH i configured is correct (and also ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2004
    Posts
    7

    KDE environment PATH


    Hi i've configured my shell to export a PATH including java, and if i log in from console, typing "set" i can see PATH i configured is correct (and also java works).
    To set my shell i created a ~/.profile file and added those lines:

    #!/bin/bash
    PATH=$PATH:/javadir
    export PATH

    Then, if i try to open a shell from KDE, PATH variable is different from the one i have logging in from the console (and without java).
    I want to be able to set the same PATH also when opening a kconsole or a shell from KDE.
    What can i do?
    I'm running Debian Sarge and KDE3.2

  2. #2
    Just Joined!
    Join Date
    Nov 2004
    Location
    A world without walls or fences...
    Posts
    47
    try putting
    set PATH=$PATH:/javadir
    export PATH
    in /home/yourname/.bashrc

  3. #3
    Just Joined!
    Join Date
    Sep 2004
    Posts
    7
    try putting
    set PATH=$PATH:/javadir
    export PATH
    in /home/yourname/.bashrc
    tried putting that lines into .bashrc, but kde continues not viewing the correct PATH :
    i launched eclipse binary from konqueror and it tells JRE is required, even if i can launch eclipse from a kconsole, because into the shell PATH is correct.
    could you help me?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Dec 2004
    Posts
    2
    hi, just ran into the exact same problem. I thought that if the KDE environment variables are different, it is certainly because there is a conf file somewhere that overrides the default system wide settings.

    and I found it after reading the PATH HOWTO: you need to edit the conf file to your display manager. If you use gdm as i do, it is /etc/gdm/gdm.conf. Open it as root in the editor of your choice and add the path to your java bin folder into the DefaultPath statement. (mine is /usr/local/jre1.5.0/bin, but yours may be different). It should work like this, however, I havent had the time to try it out.

    hope that helps.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •