Find the answer to your Linux question:
Results 1 to 7 of 7
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Grub2 and squeeze/Debian 6.0.2 problems?

    Guys: Has anyone reported a problem with Debian squeeze (specifically 6.0.2 & 3) having problems installing Grub2 during a fresh install?

    Also here's the fun part. I just tried to install 6.0.2 on a netbook and right when it tried to install Grub2 it said it couldn't. LILO won't install as well.

    Since I need a working system, I went back and installed my old 5.0.3 on the netbook and didn't have a bit of problem.

    Can someone point me to something that will make Grub2 install correctly? I've used the SystemrescueCD and it won't work. Is the current version of Grub2 actually damaged in someway? Is there a way to get at least legacy GRUB installed so I can get into my system? I don't need fancy stuff, just a menu to select a kernal, or OS.

  2. #2
    You need to post more information - exact error messages are useful, vague stuff like "LILO won't install" and "it won't work" are not helpful.

    During the setup you are given the option as to where to install grub, what are you selecting at that point? Do you have more than one hard disk, how are they partitioned?

  3. #3
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Either at home or at work or down the pub
    I installed squeeze on a desktop machine just yesterday and had no problems with Grub. It will be going on to a laptop tonight or tomorrow (what an exciting way to spend a Friday night!) so I'll see if I get any issues then.

    Does your netbook have any kind of boot loader protection that Grub 2 respects?
    Should you be sitting wondering,
    Which Batman is the best,
    There's only one true answer my friend,
    It's Adam Bloody West!

    The Fifth Continent

  4. $spacer_open
  5. #4

    New info.

    Ok, since my last install came up dead after an upgrade, I tried another install of 6.0.2 just for you guys:

    This is on an Asus Eee 1000HA, 2g memory, 160g SATA HD 1.6ghz.

    I use the text installer, instead of the graphical one, since the text one works 99% of the time, while the graphic is at best hit or miss. I also do the standard install, instead of the expert - but I've used the expert before too. This is just faster.


    First got to the partitioner, and I suspected something I did there, may be the problem. So:

    Manual partition:
    Created empty partition (to wipe it clean)

    Partition #1: 10g, Primary, Location: Beginning, used EXT3 for the file system, made it bootable, and set it /.

    Partition #2: 5g, logical, location: beginning: Set it SWAP

    Partition #3: 145g, Logical, set it EXT4, set it for: Noexec, and sync, set it as /home

    Now at: 'installing grub2'

    Retrieving files 1 of 4

    The grub-pc package failed to install into /target/. Without the grub bootloader, the installed system will not boot.

    Then it aborts to a menu of things to do (like the expert install menu) so tried Lilo

    installed it to /dev/sda: Master boot record.
    asked about the large memory option? Y

    then asked if it needs to run the /sbin/lilo: Y

    It installed Lilo, and the system boots. There is no OS/kernel menu, but I'm assuming that appears /after/ a new kernel is installed? I've never used Lilo.

    One question though. I've imaged and restored / before using partimage, and I thought it reinstalls the GRUB2 as well. But sometimes it doesn't seem too. Does partimage back up the Grub2 and reinstall it? Or was that just an old grub still in the MBR? If so, is there someway I can backup and reinstall Grub2 as well? Grub has been one of 3 major brick-walls I have with linux

    Thanks for the replies.

  6. #5
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Either at home or at work or down the pub
    After a bit of Googling, your grub problem seems to be a very common one with eeepcs. The solution seems to be to boot to a rescue session and to reinstall grub-pc and here's how. Replace wheezy with squeeze in the repositories.

    In lilo, IIRC, you need to press Tab to see the menu. I'm afraid I have no idea about your partimage query.
    Should you be sitting wondering,
    Which Batman is the best,
    There's only one true answer my friend,
    It's Adam Bloody West!

    The Fifth Continent

  7. #6
    my old squeeze disk did this as well. when you install it you should do the expert install. after you install the base system, and packages if you want them drop to a shell and do:

    mount --bind /dev /target/dev && mount --bind /proc /target/proc && chroot /target

    then do a:

    install-grub && update-grub

  8. #7

    Problem SOLVED

    Just wanted to write, and thank everyone for their advice. I finally found the problem.

    The text installer apparently has some sort of unknown 'feature' or bug, depending on your POV. If you plug in the computer when you start, it'll set up the network and time Then unplug (or turning off) the modem after this step will make the installer install from the CD/DVD

    But if you leave it plugged in until it starts configuring APT, it'll start downloading stuff from the servers, even if you use a DVD. With my slow connection, that'd take 6 hours - meaning around 600+ megs of stuff.

    What's worse, if you pull the plug after the APT configuration, it'll screw everything up. (That's what I was doing before)

    I ran into the installer not installing the GUI, it would also screw up GRUB, Lilo, and even if these things worked, the OS still had problems; ran into some bizarre problems then.

    I tested this by installing Debian 6.0.3/XFCE4 on a netbook and Thinkpad. Worked like a charm if I turned off the modem at the right time.

    So there you have it, is there a tips section for newbies here I can point this too?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts