Find the answer to your Linux question:
Results 1 to 7 of 7
I need some help... i was cruising right along with my new Debian Squeeze installation... I had run through this completely: howtoforge.com/perfect-server-debian-squeeze-with-bind-and-courier-ispconfig-3 I was messing with getting the network setup ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2012
    Posts
    4

    Loading initial ramdisk freeze


    I need some help... i was cruising right along with my new Debian Squeeze installation... I had run through this completely: howtoforge.com/perfect-server-debian-squeeze-with-bind-and-courier-ispconfig-3

    I was messing with getting the network setup properly and decided the console resolution was too small so I changed some grub configuration according to this: lists.debian.org/debian-user/2011/01/msg00611.html

    I had rebooted 3 or 4 times prior to changing the grub config without issue... after rebooting this time, the following happened:

    Loading Linux 2.6.32-5-amd64 ...
    Loading initial ramdisk ...

    And that's it. Nothing else happens...

    in Recovery mode, pressing e gets me this...

    Code:
    set gfxpayload=keep
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos1)'
    search --on-floppy --fs-uuid --set a5551ad8-0223-406b-909e-af3951302129
    echo 'Loading Linux 2.6.32-5-amd64 ...'
    linux /boot/vmlinuz=-2.6.32-5-amd64 root =UUID=a5551ad8-0223-406b-909e-af3951302129 ro single
    echo 'Loading initial ramdisk'
    initrd /boot/initrd.img-2.6.32-5-amd64
    I am new to Linux, so i am very lost as to what could have happened.

    Can anyone help?

    PS... I was unable to post URL due to my newness on the forums (a bit ridiculous) so sorry for the shortened versions of the URLs.

  2. #2
    Guest
    Join Date
    Feb 2005
    Posts
    312
    No idea what happened there, but if I was to guess I'd say that you made a syntax error editing the grub config?

    GrubRecover - Debian Wiki

  3. #3
    Just Joined!
    Join Date
    Mar 2012
    Posts
    4
    Well, I was able to get into the grub file and comment out the two lines I added... ran update-grub again and all was well! I was able to reboot... and the system came up!

  4. $spacer_open
    $spacer_close
  5. #4
    Guest
    Join Date
    Feb 2005
    Posts
    312
    Can you post up the contents of the file which you have edited and indicate those lines - for future reference (+ someone might be able to assist you in doing what you're trying to do)?

  6. #5
    Just Joined!
    Join Date
    Mar 2012
    Posts
    4
    I actually tried many different things... I'll see if I can list them all and the reaction the system gave.

    First, following the link in my original post, I edited /etc/default/grub. I commented out
    Code:
    GRUB_GFXMODE=640x480
    and added the lines
    Code:
    GRUB_GFXMODE=1366x768x32
    GRUB_GFXPAYLOAD_LINUX=keep
    This broke the system. I removed the added lines and uncommented the 640x480 line and the system acted normally.

    I then went one by one (after discovering that 1366x768 was not supported by my graphics card)... I changed
    Code:
    GRUB_GFXMODE=640x480
    to
    Code:
    GRUB_GFXMODE=1280x800
    rebooted and the machine booted but without a console that was 1280x800. The GRUB boot up screen, however, WAS 1280x800. Confused, I went digging and attempted to change /etc/grub.d/00_header (found from this post here: harrison3001.blogspot.com/2009/09/grub-2-graphical-boot-tips-to-set.html#.T2ne_REgfng. I set the gfxpayload in this file, rebooted and the system failed.

    I then went for the gold medal and attempted to edit the grub.cfg file directly. I set the lines in question, but neither took effect. However, the system did not break! But, I still don't have a console that is above 640x480.

    All in all, a failure and with my lack of Linux kernel knowledge, I gave up and will just use Putty!

    By the way, after EVERY update to the grub config files, I ran update-grub. And the ONLY way to restore the system after it failed was to boot to the ISO in recovery mode, set up shell access to the root and reedit the files I changed.

    Hope this helps someone in the future!
    Last edited by cbeyer; 03-21-2012 at 02:41 PM.

  7. #6
    Guest
    Join Date
    Feb 2005
    Posts
    312
    There are some errors there such as "GRUB_GFXLOAD" which should be "GRUB_GFXPAYLOAD". (//edit: I see you edited those.)

    Have a look at jheaton5's post on the Debian forums: Debian User Forums • View topic - Grub2 and framebuffer

    If you want to work on a clean configuration, purge your current grub installation first and reinstall from fresh (you will need to purge otherwise it will keep the same config files).

    That one always works for me. Use 1024x768 - anything higher or even native res may result in a blank screen. Make sure you do "update-grub" as root after making changes.

  8. #7
    Just Joined!
    Join Date
    Mar 2012
    Posts
    4
    Actually, it should be GRUB_GFXMODE! My bad on that...

    I attempted jheaton5s advice... to no avial.

    I went with 800x600 and 1024x768 with and without the 32 (which I assume is color) and each time it resulted in a blank screen.

    Owell, enough time has been spent! Moving on to other things... so much to learn.

    Thanks for all your help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •