Find the answer to your Linux question:
Results 1 to 9 of 9
I have an application that has to run PHP 5.3. No matter what I try PHP 5.4 keeps getting installed. I've been going over Google for hours and nothing works. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2012
    Posts
    5

    Can't install PHP 5.3 on Debian Squeeze, it seems to force 5.4


    I have an application that has to run PHP 5.3. No matter what I try PHP 5.4 keeps getting installed. I've been going over Google for hours and nothing works. I can't post links so I can't be more specific in what I've followed. Apart from more specific guides I followed a more generic guide for installing specific versions which came out as apt-get install php5=5.3.3-7+squeeze3 and it installed 5.4. I'm completely lost here.

    Thanks,
    Dan

  2. #2
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,482
    It looks like you are tracking the testing repositories. PHP in stable and PHP in testing. I've not found anything on Startpage specifically about this, but you might be able to do something with apt pinning but I wouldn't recommend it.

    The different builds might require different libraries which can cause a whole world of pain.

    Which application is it?
    Have you tried in on PHP 5.4?
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    Conkybots: Interactive plugins for your Conkys!

  3. #3
    Just Joined!
    Join Date
    Apr 2012
    Posts
    5
    I'm trying to install Ubersmith (for development purposes), it's ioncube encoded and they state that it must run on 5.2 or 5.3 among a long list of other requirements.

  4. #4
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,482
    The only requirements I can find are form 2010. It may be worth using their live chat to ask them directly about PHP 5.4
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    Conkybots: Interactive plugins for your Conkys!

  5. #5
    Just Joined!
    Join Date
    Apr 2012
    Posts
    5
    I contacted them and they told me it was untested and unsupported. I went ahead and I am getting critical errors with the scripts, they told me that to get rid of them I'll need to get PHP 5.3 or 5.2 on my system and that I need to go to Linux support channels for that. While I strongly doubt the errors I am facing are caused by 5.4 they aren't going to be of any help with their closed source script until I get it.

    Am I going to need to ditch the package managers and build the stuff myself?

  6. #6
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,482
    You have various options: (I'm assuming this is a development box and not a production one)

    1. Install Debian stable which currently has PHP 5.3
    2. Uninstall PHP 5.4 and manually build PHP 5.3
    3. Attempt to manually build and install PHP 5.3 alongside PHP 5.4
    4. Consider this as an alternative to Ubersmith.

    I have no experience of Ubersmith or WHMCS so I make no recommendation either way.
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    Conkybots: Interactive plugins for your Conkys!

  7. #7
    Just Joined!
    Join Date
    Apr 2012
    Posts
    5
    I'll probably do #2, I'll contact my host about it.

    As for #4, I'm a programmer who's developing a product for Ubersmith so I'm sort of stuck.
    Last edited by danberliner; 04-21-2012 at 07:12 PM.

  8. #8
    Linux Engineer
    Join Date
    Apr 2012
    Location
    Virginia, USA
    Posts
    882
    Quote Originally Posted by danberliner View Post
    I have an application that has to run PHP 5.3. No matter what I try PHP 5.4 keeps getting installed. I've been going over Google for hours and nothing works. I can't post links so I can't be more specific in what I've followed. Apart from more specific guides I followed a more generic guide for installing specific versions which came out as apt-get install php5=5.3.3-7+squeeze3 and it installed 5.4. I'm completely lost here.

    Thanks,
    Dan
    I would highly recommend switching to Debian stable.

    Anyway, you won't be able to install php5.3x from the testing repos, because it's not included.
    You could add debian stable to your /etc/apt/sources.list but I have never tried this and I don't know what results you'll get.

    deb http <colon> //ftp.debian.org/debian squeeze main contrib non-free
    deb http <colon> //security.debian.org squeeze/updates main contrib non-free

    Of course, you can substitute your preferred mirrors for the ones above.

  9. #9
    Just Joined!
    Join Date
    Apr 2012
    Posts
    5
    Quote Originally Posted by mizzle View Post
    I would highly recommend switching to Debian stable.

    Anyway, you won't be able to install php5.3x from the testing repos, because it's not included.
    You could add debian stable to your /etc/apt/sources.list but I have never tried this and I don't know what results you'll get.

    deb http <colon> //ftp.debian.org/debian squeeze main contrib non-free
    deb http <colon> //security.debian.org squeeze/updates main contrib non-free

    Of course, you can substitute your preferred mirrors for the ones above.
    Replacing my entire sources list (I made a backup) did it, I'm running 5.3.3-7. Thanks! The solution actually made sense. Getting this issue was sort of a kick to the groin since I was just beginning to feel comfortable with Linux and my knowledge of it.

    edit: The scripts are running perfectly after all, I guess it was version troubles.
    Last edited by danberliner; 04-23-2012 at 06:27 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •