Find the answer to your Linux question:
Results 1 to 2 of 2
Hi all, I'm trying to capture traffic via Wireshark on a host running Ubuntu liveCD. At first, it won't catch any interface to capture on. Gogling I saw this website ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2012
    Posts
    10

    Failed to set capabilities


    Hi all,

    I'm trying to capture traffic via Wireshark on a host running Ubuntu liveCD. At first, it won't catch any interface to capture on. Gogling I saw this website where they give you instructions to set it up and getting it running (first link when googling "capture priviliges wireshark wiki")

    Everything goes fine until introducing the line:

    "setcap 'CAP_NET_RAW+eip CAP_NET_ADMIN+eip' /usr/bin/dumpcap"

    The terminal gives me the following message:
    Faile to set capabilities on file '/usr/bin/dumpcap' (Operation not supported) usage...
    Note: <filename> must be a regular (non-symlink) file.

    Ok, I tried:
    cd /usr/bin/
    readlink -v dumpcap

    and it says:

    readlink: dumpcap: Invalid argument

    Anyone knows what is happening and how can I get it solved?

    Thanks in advance!

  2. #2
    Just Joined!
    Join Date
    Feb 2010
    Posts
    25
    I think you are not running wireshark as a root user. Try running wireshark by the following command.

    sudo wireshark

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •