Find the answer to your Linux question:
Results 1 to 6 of 6
Like Tree1Likes
  • 1 Post By descendant_command
Hi, I Tried the command "apt-get install heartbeat" to install in debian 6.0.4 but it is not working and says that "Unable to locate package" Please help me to install ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2012
    Posts
    6

    How to install heartbeat in debian6.0.4?


    Hi,
    I Tried the command "apt-get install heartbeat" to install in debian 6.0.4 but it is not working and says that "Unable to locate package"

    Please help me to install it

    Thanks

  2. #2
    Just Joined!
    Join Date
    Nov 2011
    Location
    New Zealand
    Posts
    79
    Did you refresh the repository lists with
    Code:
    apt-get update
    before you tried to install the heartbeat package?

  3. #3
    Just Joined!
    Join Date
    May 2012
    Posts
    6
    yes I tried that..

  4. #4
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,128
    Squeeze has it

    Debian -- Details of package heartbeat in squeeze

    I run testing

    Code:
    harry@biker:~$ apt-cache policy heartbeat
    heartbeat:
      Installed: (none)
      Candidate: 1:3.0.5-3
      Version table:
         1:3.0.5-3 0
            901 http://ftp.us.debian.org/debian/ testing/main i386 Packages
    harry@biker:~$ cat /etc/apt/sources.list
    # See sources.list(5) for more information
    
    # Note:If you want maximum stability, only use the stable repos.
    # If you want to install kde3.5, you MUST only use the stable repos.
    
    # Debian
    # deb http://ftp.ca.debian.org/debian/ stable main contrib non-free
    deb http://ftp.us.debian.org/debian/ testing main contrib non-free
    deb http://security.debian.org/ testing/updates main contrib non-free
    # deb-src http://ftp.ca.debian.org/debian/ stable main contrib non-free
     
    # mplayer
    # deb http://www.debian-multimedia.org stable main non-free
    #deb http://www.debian-multimedia.org testing main non-free
    
    # opera
    #deb http://deb.opera.com/opera/ testing non-free
    
    # virtualbox
    # deb http://download.virtualbox.org/virtualbox/debian lenny non-free
    
    # liquorix kernels
    # deb http://liquorix.net/debian/ sid main
    
    ###### Debian Unstable/Sid##########
    ###### Use at your own risk! ########
    # deb http://ftp.ca.debian.org/debian/ unstable main contrib non-free
    # deb http://www.debian-multimedia.org unstable main non-free
    
    ######Trinity KDE 3.5.13 Debian Squeeze#######
    #deb http://ppa.quickbuild.pearsoncomputing.net/trinity/trinity-v3.5.13/debian squeeze main
    #deb-src http://ppa.quickbuild.pearsoncomputing.net/trinity/trinity-v3.5.13/debian squeeze main
    #deb http://ppa.quickbuild.pearsoncomputing.net/trinity/trinity-builddeps-v3.5.13/debian squeeze main
    #deb-src http://ppa.quickbuild.pearsoncomputing.net/trinity/trinity-builddeps-v3.5.13/debian squeeze main
    
    harry@biker:~$ cat /etc/issue
    Debian GNU/Linux wheezy/sid \n \l
    I uncomment multimedia repos and mplayer repos only when I wish to update certain applications and comment them back out during dist-upgrades. After a apt-get update.
    Code:
    apt-cache policy hearbeat
    Should show if you have the right repositories enabled in squeeze, Since you did not post your /etc/.apt/sources.list like I did. Kinda hard to tell you why you did not find heartbeat.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  5. #5
    Just Joined!
    Join Date
    May 2012
    Posts
    6
    Thanks rokytnji
    I could not post http, ftp, @ thus please read htp as http and fp as ftp and also there is no space before and after // (for making url)
    I run the command and I got the errors:
    Code:
     apt-get install heartbeat
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     initscripts : Breaks: console-setup (< 1.74) but 1.68+squeeze2 is to be installed
                   Breaks: nfs-common (< 1:1.2.5-3) but 1:1.2.2-4squeeze2 is to be installed
     libglib2.0-0 : Breaks: eog (< 3.2.2-3) but 2.30.2-1 is to be installed
                    Breaks: gnome-control-center (< 1:3) but 1:2.30.1-2 is to be installed
     libgnome-keyring0 : Breaks: gnome-keyring (< 3.0) but 2.30.3-5 is to be installed
     network-manager : Recommends: crda but it is not going to be installed
                       Breaks: network-manager-gnome (< 0.9) but 0.8.1-2 is to be installed
    E: Broken packages
    Here is my /etc/apt/sources.list file
    Code:
    :~# cat /etc/apt/sources.list
    # 
    
    # deb cdrom:[Debian GNU/Linux 6.0.4 _Squeeze_ - Official i386 DVD Binary-1 20120128-12:53]/ squeeze contrib main
    
    deb cdrom:[Debian GNU/Linux 6.0.4 _Squeeze_ - Official i386 DVD Binary-1 20120128-12:53]/ squeeze contrib main
    
    deb http: // security.debian.org/ squeeze/updates main contrib
    deb-src htp: // security.debian.org/ squeeze/updates main contrib
    
    deb htp: // fp.us.debian.org/debian/ testing main contrib non-free
    deb htp: // security.debian.org/ testing/updates main contrib non-free
    
    deb htp: // fp.cn.debian.org/debian squeeze main
    deb htp: // fp.ca.debian.org/debian/ stable main contrib non-free
    # squeeze-updates, previously known as 'volatile'
    # A network mirror was not selected during install.  The following entries
    # are provided as examples, but you should amend them as appropriate
    # for your mirror of choice.
    #
    # deb htp: // fp.debian.org/debian/ squeeze-updates main contrib
    # deb-src htp: // fp.debian.org/debian/ squeeze-updates main contrib
    ~#
    Now how this could be solved?
    Thanks

  6. #6
    Just Joined!
    Join Date
    Apr 2012
    Posts
    10
    You have both squeeze AND testing repo's enabled.
    Depending on what you have installed from testing you may already be beyond sensible repair.

    Remove the testing line (and the dvd), do an 'aptitude update' and 'aptitude full-upgrade'.
    Post the output.
    rokytnji likes this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •