Find the answer to your Linux question:
Results 1 to 7 of 7
After upgrading to 12.04 my java plugin does not work. I have tried a lot of solutions but am still stuck and really need help. The issue may that I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2012
    Posts
    4

    Angry Problem getting oracle 6.32 java plugin working with firefox


    After upgrading to 12.04 my java plugin does not work. I have tried a lot of solutions but am still stuck and really need help. The issue may that I have tried a lot of solutions and ended up with some weird settings. Here is what I have.

    java -version

    java version "1.6.0_32"
    Java(TM) SE Runtime Environment (build 1.6.0_32-b05)
    Java HotSpot(TM) Server VM (build 20.7-b02, mixed mode)

    This is the only java installed. I have purged openjdk. So update-alternatives shows only my jdk1.6.0_32 as expected. So all I need is to link my libnpjp2.so with firefox.

    I've attempted linking in many ways but nothing seems to work. I've been trying to get this working for days, any help appreciated.

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    this works for me:

    1. clean all extraneous java from system

    2. download "jre-6u32-linux-i586.bin" from JRE 6u32 Downloads

    3. change dir to /opt (where i want to install java) and execute the .bin file:
    Code:
    cd /opt
    /path/to/jre-6u32-linux-i586.bin
    NOTE: you may have to mark the .bin file executable.

    4. change dir to my system's mozilla/firefox plugins directory:
    Code:
    cd /usr/lib/mozilla/plugins
    NOTE: you dir is probably different.

    5. create a symlink pointing to the java plugin, e.g.:

    Code:
    ln -s /opt/jre1.6.0_32/lib/i386/libnpjp2.so
    that's it - java in firefox now works (for me). you may have to update your version of Firefox, too, if it is still not happy.

  3. #3
    Just Joined!
    Join Date
    Jun 2012
    Posts
    4
    Thanks for the response.

    I will attempt this ASAP and let you know if it works. One note, I am using the jdk not jre, does this make any difference that I am pointing to the jdks jre?

  4. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    i think the jdk has the jre+jdk, so you should be fine. just make sure the path is correct when you perform the link command.

  5. #5
    Just Joined!
    Join Date
    Jun 2012
    Posts
    4
    Still stuck. I suspect that something may have been broken with all my fumbling around trying to get this working. I'm not sure what though. As I said it was working prior to the upgrade. I am on a 64bit system, as this worked previously don't think that is an issue, however I have installed the compatibility libraries ia32-libs.

  6. #6
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    have you tried installing the 64-bit version of Java? see this for more info:

    JDK RPM 64-bit Installation

  7. #7
    Just Joined!
    Join Date
    Jun 2012
    Posts
    4
    I finally got it working by running the commands below

    sudo apt-get remove firefox openjdk-6-jdk icedtea-6-plugin
    sudo apt-get install firefox:i386 openjdk-6-jdk:i386 icedtea-6-plugin:i386

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •