Find the answer to your Linux question:
Results 1 to 5 of 5
I just upgraded my Debian Lenny to Squeeze. The problem is, I'm using an old IBM PS/2 monitor that won't support anything other than the plain old standard 80x25 screen. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2004
    Posts
    8

    Disable framebuffer console after upgrade from Lenny to Squeeze


    I just upgraded my Debian Lenny to Squeeze. The problem is, I'm using an old IBM PS/2 monitor that won't support anything other than the plain old standard 80x25 screen. (Not even 80x50 is compatible.) Grub got upgraded from 0.9 to 2, and I successfully got it to stop using the framebuffer. The problem I can't figure out how to fix is, once it starts to boot up, the console goes into framebuffer mode.

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    have you tried disabling FB in the grub config file? See the following article for how to do it. It is for Arch Linux, but should apply.

    https://wiki.archlinux.org/index.php...le_framebuffer

  3. #3
    Just Joined!
    Join Date
    Apr 2004
    Posts
    8
    Not so much. I had already managed to get grub to not use framebuffer by using GRUB_GFXMODE=text. There was a comment in /etc/default/grub that said:
    Code:
    # Uncomment to disable graphical terminal (grub-pc only)
    # GRUB_TERMINAL=console
    I uncommented that line, and added GRUB_TERMINAL_OUTPUT=console as suggested by your link, but it still only affects grub.

    Once the system boots, the last thing I see on screen is "waiting for devfs to be fully populated" (or something like that) before the screen goes all wonky as the video mode is switched out of the monitor's range.

    In /var/log/messages, I see this:
    Code:
    Jul 27 07:03:46 independence kernel: [    8.166421] nouveau 0000:01:0a.0: PCI INT A -> Link[APC3] -> GSI 18 (level, low) -> IRQ 18
    Jul 27 07:03:46 independence kernel: [    8.169810] [drm] nouveau 0000:01:0a.0: Detected an NV 0 generation card (0x20044001)
    Jul 27 07:03:46 independence kernel: [    8.169902] [drm] nouveau 0000:01:0a.0: Attempting to load BIOS image from PROM
    Jul 27 07:03:46 independence kernel: [    8.287119] [drm] nouveau 0000:01:0a.0: ... appears to be valid
    Jul 27 07:03:46 independence kernel: [    8.287434] [drm] nouveau 0000:01:0a.0: BMP BIOS found
    Jul 27 07:03:46 independence kernel: [    8.287437] [drm] nouveau 0000:01:0a.0: BMP version 0.1
    Jul 27 07:03:46 independence kernel: [    8.287440] [drm] nouveau 0000:01:0a.0: Assuming a CRT output exists
    Jul 27 07:03:46 independence kernel: [    8.287443] [drm] nouveau 0000:01:0a.0: Probing TV encoders on I2C bus: 0
    Jul 27 07:03:46 independence kernel: [    8.300308] [drm] nouveau 0000:01:0a.0: No TV encoders found.
    Jul 27 07:03:46 independence kernel: [    8.314377] [TTM] Zone  kernel: Available graphics memory: 257316 kiB.
    Jul 27 07:03:46 independence kernel: [    8.314392] [drm] nouveau 0000:01:0a.0: 16 MiB VRAM
    Jul 27 07:03:46 independence kernel: [    8.323897] [drm] nouveau 0000:01:0a.0: 64 MiB GART (aperture)
    Jul 27 07:03:46 independence kernel: [    8.324142] [drm] nouveau 0000:01:0a.0: Saving VGA fonts
    Jul 27 07:03:46 independence kernel: [    8.373141] [drm] nouveau 0000:01:0a.0: Detected a VGA connector
    Jul 27 07:03:46 independence kernel: [    8.373893] [drm] nouveau 0000:01:0a.0: Setting dpms mode 3 on vga encoder (output 0)
    Jul 27 07:03:46 independence kernel: [    8.412440] [drm] nouveau 0000:01:0a.0: Load detected on head A
    Jul 27 07:03:46 independence kernel: [    8.412937] ACPI: PCI Interrupt Link [APCJ] enabled at IRQ 22
    Jul 27 07:03:46 independence kernel: [    8.412944] Intel ICH 0000:00:04.0: PCI INT A -> Link[APCJ] -> GSI 22 (level, low) -> IRQ 22
    Jul 27 07:03:46 independence kernel: [    8.441375] [drm] nouveau 0000:01:0a.0: allocated 1024x768 fb: 0x44000, bo d790d600
    Jul 27 07:03:46 independence kernel: [    8.518195] [drm] nouveau 0000:01:0a.0: Setting dpms mode 0 on vga encoder (output 0)
    Jul 27 07:03:46 independence kernel: [    8.518200] [drm] nouveau 0000:01:0a.0: Output VGA-1 is running on CRTC 0 using output @
    Jul 27 07:03:46 independence kernel: [    8.546427] Console: switching to colour frame buffer device 128x48
    Jul 27 07:03:46 independence kernel: [    8.574877] fb0: nouveaufb frame buffer device
    I suspect there might be a parameter I could pass to the nouveau module, but I don't seem to be having much luck googling. I have a nouveau.conf file in /etc/modprobe.d
    Code:
    options nouveau noaccel=1
    to disable hardware acceleration, as I did manage to stumble across a thread post complaining about a blank display and the syslog filling with error messages on a Diamond Viper V550 card (which is exactly what I have, and I was seeing those errors too).

    But I still can't see anything on the old CRT.

  4. $spacer_open
    $spacer_close
  5. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    what about appending the following kernel boot parameters:

    Code:
    vga=normal nomodeset

  6. #5
    Just Joined!
    Join Date
    Apr 2004
    Posts
    8
    Quote Originally Posted by atreyu View Post
    what about appending the following kernel boot parameters:

    Code:
    vga=normal nomodeset
    That did the trick. Thank you!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •