Find the answer to your Linux question:
Results 1 to 3 of 3
This worked fine two days ago for years: # mount -t nfs myserver:/mnt/c1d0p1 /net/myserver/c1d0p1 nfs mounted, spool backups there, done. Now: # mount -t nfs myserver:/mnt/c1d0p1 /net/myserver/c1d0p1 mount: wrong fs ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2012
    Posts
    4

    nfs client hosed after upgrade


    This worked fine two days ago for years:

    # mount -t nfs myserver:/mnt/c1d0p1 /net/myserver/c1d0p1

    nfs mounted, spool backups there, done.

    Now:

    # mount -t nfs myserver:/mnt/c1d0p1 /net/myserver/c1d0p1

    mount: wrong fs type, bad option, bad superblock on ixtlan:/mnt/c1d0p1,
    missing codepage or helper program, or other error
    (for several filesystems (e.g. nfs, cifs) you might
    need a /sbin/mount.<type> helper program)
    In some cases useful info is found in syslog - try
    dmesg | tail or so

    That's happening on 2 Linux boxes now - unable to connect via nfs. Temp solution is to boot the machines with a RIP disk and do things from there.

  2. #2
    Linux Newbie hagfish52's Avatar
    Join Date
    Dec 2011
    Location
    Asheville, NC
    Posts
    225

  3. #3
    Just Joined!
    Join Date
    Aug 2012
    Posts
    4
    That worked, thanks!

    #apt-get install nfs-common


    Setting up nfs-common (1:1.2.6-3) ...
    Installing new version of config file /etc/init.d/nfs-common ...
    Replacing config file /etc/idmapd.conf with new version
    [ ok ] Stopping NFS common utilities: idmapd statd.
    [ ok ] Starting NFS common utilities: statd idmapd.
    Processing triggers for sgml-base ...
    Updating the super catalog...
    Setting up docbook-xml (4.5-7.1) ...
    Processing triggers for sgml-base ...
    Updating the super catalog...


    - and the other machine which had the same issue apparently fixed itself, works too..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •