Find the answer to your Linux question:
Results 1 to 5 of 5
Hey there, I did find a lot on the internet about this problem but it looked like nothing worked for me. I want a static ip on my server and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2012
    Posts
    12

    Question Error Could not resolve, tried a lot. but need help


    Hey there,

    I did find a lot on the internet about this problem but it looked like nothing worked for me. I want a static ip on my server and afther this i got some problems with using the apt-get command. Can somewone help me with cleaning up my settings and letting me download and install packages? Some people say it is a DNS problem how can i check if that is the problem?

    error when typing aptitude update: pastebin.com/gyqyajH3
    sources.list file: pastebin.com/3B6L8KxP
    hosts: pastebin.com/iEEEh75s
    ifconfig: pastebin.com/yRbcAwA9

    Hopefully someone can help me with this problem.

    Thank you for reading!

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,807
    What is the default route that you have set for this? If you're trying to use a gateway address that's not in your local network (i.e. if your gateway isn't 192.168.178.x) then you may struggle to talk to the internet. If your gateway is 192.168.1.1 or similar, then you should be using a static IP in the same range, 192.168.1.x.
    Linux user #126863 - see http://linuxcounter.net/

  3. #3
    Just Joined!
    Join Date
    Aug 2012
    Posts
    12
    Thank you for really fast reply,

    I got a static ip and my gateway is 192.168.178.x. I post a picture from my router so you can check if it is correct or not.
    network info kopie.jpg

  4. #4
    Just Joined!
    Join Date
    Aug 2012
    Posts
    12
    When i look more in my router I see that when my pc is running i don't see it under users (in dutch: Gebruikers). I think i screwed up my static ip. Maybe it is smart to first reverse this back? How do i do that? Or did install my static ip just fine?
    Picture of my users in router (when my pc is running, and i can also connect to it with ssh)users kopie.jpg

    thankyou.

  5. #5
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,807
    To reverse it you just turn on DHCP on your computer again. In fact you probably want to do this, and reconnect. Once it's on take a note of the gateway and DNS server addresses you've been assigned by the DHCP server in your router, and re-use those values in your static IP config.

    You may not be in that 'users' list you posted because it might be a list of the DHCP assigned addresses.

    Another thing you need to be careful to configure is the DHCP server itself. You should ensure that the static IP address you've chosen is not in the range that could be assigned by the DHCP service.

    Being able to connect by SSH suggests your static IP address is working, but that the internet isn't available. If your gateway is set up right, then it's likely to be a DNS lookup problem.
    Linux user #126863 - see http://linuxcounter.net/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •