Find the answer to your Linux question:
Results 1 to 2 of 2
I am trying to build and install freeswitch on Raspberry PI computer in order to use skype and asterisk. When I run this command - insmod ./skypopen.ko I get this ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2012
    Posts
    1

    insmod error - Device or resource bus


    I am trying to build and install freeswitch on Raspberry PI computer in order to use skype and asterisk.

    When I run this command - insmod ./skypopen.ko
    I get this error- Error: could not insert module ./skypopen.ko: Device or resource busy

    I ran 'lsmod|grep snd' earlier and it showed some modules. I used rmmod to remove them. Now 'lsmod' does not show any modules. I still get the device busy error when I run insmod.

    How can I fix this error?

  2. #2
    Linux Newbie objuan's Avatar
    Join Date
    Jul 2006
    Location
    california
    Posts
    234
    Hello,
    Try using modprobe it is a more functional program for adding an removing mods.
    read the man pages for useage
    man modprobe
    --------------------------
    Linux is the FORCE

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •