Find the answer to your Linux question:
Results 1 to 2 of 2
Hi all, Fedora 17 64bit Debian 6.0.6 64bit Dualboot On Debian ran; # apt-get -t squeeze-backports install linux-image-3.2.0-0.bpo.3-amd64 firmware-linux-free Rebooted New kernel not found on GRUB prompt only old kernel ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,778

    Debian not displayed on GRUB window


    Hi all,

    Fedora 17 64bit
    Debian 6.0.6 64bit
    Dualboot

    On Debian ran;
    # apt-get -t squeeze-backports install linux-image-3.2.0-0.bpo.3-amd64 firmware-linux-free

    Rebooted
    New kernel not found on GRUB prompt only old kernel there
    Code:
    Linux version 2.6.32-5-amd64 (Debian 2.6.32-46)
    Debian still can be booted.

    Then on Fedora ran;
    $ sudo grub2-mkconfig -o /boot/grub2/grub.cfg

    Rebooted and on GRUB prompt Debian new kernel was still not displayed. The new kernel was found under "Advanced Option" of Debian.

    Started Debian with new kernel a black screen displayed finally. Pressed [Ctrl]+[Alt]+/F1/F2/F4 etc with no action.

    Then forced-rebooted PC and booted Debian new kernel recovery mode. It was dropped to Shell.

    Then I ran;
    # blkid
    found the device of Debian

    # fsck -yf /dev/sda3 (device of Debian)

    Rebooted.

    Debian is now completely not shown up on GRUB prompt.

    Please help. TIA

    B.R.
    satimis

  2. #2
    Just Joined!
    Join Date
    Apr 2013
    Posts
    69
    Hi

    Hope this might help you.

    #!/bin/sh -e
    echo "Adding my custom Linux to GRUB 2"
    cat << EOF
    menuentry "My custom Linux" {
    set root=(hd0,5)
    linux /boot/vmlinuz
    initrd /boot/initrd.img
    }
    EOF
    found at

    h t t p : / / d e d o i m e d o . c o m / c o m p u t e r s / g r u b - 2 . h t m l # m o z T o c I d 5 8 4 6 9 1

    sorry for the spaces. I can't past any URL's here.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •