Find the answer to your Linux question:
Results 1 to 3 of 3
Hi, I just bought a hp photosmart 5520. I tried both the automatic installer and the manual installer from hplipopensource. HP Linux Imaging and Printing. but i have two dependencies ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2012
    Posts
    2

    Need help on installing latest hplip on debian 6.0.6


    Hi,
    I just bought a hp photosmart 5520. I tried both the automatic installer and the manual installer from hplipopensource. HP Linux Imaging and Printing. but i have two dependencies unmet.

    My system is amd64.

    "The following packages have unmet dependencies:
    libcupsimage2-dev : Depends: libtiff4-dev but it is not going to be installed
    libsane-dev : Depends: libtiff4-dev but it is not going to be installed"

    I went to synaptic to try to install libtiff4-dev but i get the following error:
    "libtiff4-dev:
    Depends: libtiff4 (=3.9.4-5+squeeze4) but 3.9.4-5+squeeze5 is to be installed"

    Any ideas how I can solve this? I really need the scanning abilities of the printer. I can print but cant scan. When I run sane-find-scanner, the following is what i get:
    "found USB scanner (vendor=0x03f0 [HP], product=0xb111 [Photosmart 5520 series]) at libusb:001:005
    # Your USB scanner was (probably) detected. It may or may not be supported by
    # SANE. Try scanimage -L and read the backend's manpage."

    I would truly appreciate if anyone can help me on this. Do let me know if i need to give more information.
    Thanks!

  2. #2
    Just Joined!
    Join Date
    May 2012
    Posts
    7
    My experience with Linux/HP printers has been good. I simply plug in the usb, turn the printer on and it installs. If this did not work, it is probably a driver problem. Installing other programs outside of synaptic may cause additional problems. Those dependencies are needed (maybe) and if they do not just go in, you must find another solution.

    From the readout you got, I suspect that printer is not fully supported yet. Did you try
    Code:
    scanimage -L
    and read the backend's manpage?

    I would continue to Google photosmart 5520 linux driver cups, or some combination of those. I would try photosmart 5520 linux driver, first.

  3. #3
    Just Joined!
    Join Date
    Nov 2012
    Posts
    2
    I got my solution after some reply from debian.net. i downgraded my libtiff4-dev to squeeze4 instead of 5. then I can could run the latest hplip installer. now it works. though i did get reply tat debian 6.0.6 will be supported in the next version of hplip that is coming out soon.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •