Find the answer to your Linux question:
Results 1 to 2 of 2
recently I have installed debian squeeze6.0.6 on amd64 fx 4100 machine.Then I issued the command apt-get upgrade which was failed and given error message as unmet dependencies. Now when I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! rupeshforu3's Avatar
    Join Date
    Dec 2012
    Location
    India
    Posts
    62

    unable to upgrade from squeeze to wheezy(testing)


    recently I have installed debian squeeze6.0.6 on amd64 fx 4100 machine.Then I issued the command apt-get upgrade which was failed and given error message as unmet dependencies. Now when I issue the command apt-get dist-upgrade again the same error messages are appearing. I have googled a lot on how to solve unmet dependencies but none worked. Please help me.

  2. #2
    Linux Engineer hazel's Avatar
    Join Date
    May 2004
    Location
    Harrow, UK
    Posts
    1,208
    Did you do an apt-get update first? This command is necessary to synchronise your local databases with the repository.

    If you are doing an major upgrade, you also need to edit the repository list in /etc/apt to reflect the new version (for example changing "squeeze" to "wheezy" or "testing". Do this first, then update, then dist-upgrade.
    "I'm just a little old lady; don't try to dazzle me with jargon!"
    www.hrussman.entadsl.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •