Find the answer to your Linux question:
Results 1 to 4 of 4
We have an LDAP server running CentOS6. The client is Debian squeeze. As the client boots up it gets some errors below. The wierd part is that after the server ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2012
    Posts
    5

    LDAP Server


    We have an LDAP server running CentOS6. The client is Debian squeeze. As the client boots up it gets some errors below. The wierd part is that after the server boots up. I am able to login with the LDAP credentials, but only locally not via ssh. I also looked at the LDAP server log files and I dont see the client attempting to reach the LDAP server when these messages are happening, but I do see the client working after the client boots up.

    nss_ldap: failed to bind to LDAP server ldap://x.x.x.x/: Can't contact server
    nss_ldap: could not search LDAP server - server is unavailable
    nss_ldap: could not connect to any LDAP server as cn=admin,dc=name,dc=com - Can't contact LDAP server

    error message repeats several times then times out.

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Hi,

    Is there a firewall running on the LDAP server?

    On the client, do you know what daemon/process is causin the nss_ldap errors? Is it starting before networking is up on the client?

  3. #3
    Just Joined!
    Join Date
    Apr 2012
    Posts
    5
    I finally got it working. It turns out it had to do with the ldap starting before the network started. created an lsb script and it worked.
    Last edited by mrjoli021; 12-19-2012 at 08:19 PM.

  4. $spacer_open
    $spacer_close
  5. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Excellent, glad you got it sorted. Will mark this thread as Solved. Note that you can do this yourself at any time using the Thread Tools link at the top of the page.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •