Find the answer to your Linux question:
Results 1 to 3 of 3
Hello, I had Debian up and going ok, until my disk had a problem. I had an Apple disk that is 320 G and when I try to install Debian ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User jkwilborn's Avatar
    Join Date
    Nov 2012
    Posts
    285

    Debian install, reqires 8 M boot partition. Don't understand?


    Hello, I had Debian up and going ok, until my disk had a problem. I had an Apple disk that is 320 G and when I try to install Debian on it, I get a complaint that the disk has no place to put yaboot, requiring 8 M. I tried to do that, but I cant change the biggest block, because Debian install is using it. What options do I have? Any suggestions would be greeted with major thanks. I kind of chicken to just 'try things' if you know what I mean...

    It now complains that I have no 'root' file system. Do I just name it that?

    Thanks

    Jack
    Last edited by jkwilborn; 12-25-2012 at 12:07 AM. Reason: Left out some information

  2. #2
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    It now complains that I have no 'root' file system. Do I just name it that?
    No. More details necessary. Did you have Debian installed on one disk, the disk went bad and you took a disk which was used by an Apple system and tried to install Debian on it??
    I'm not clear about your second sentence. You say you try to install Debian on this disk and get a complaint the disk has no place to put yaboot as Debian is usuing it. If you have Debian on it, why are you trying to install it again?

    Are you able to boot any Linux Live CD or flash drive? If you can, run fdisk -l(Lower case Letter L in the command) as root and df -h command and post the output.

  3. #3
    Linux User jkwilborn's Avatar
    Join Date
    Nov 2012
    Posts
    285
    The disk (HD) has since been fdisk'd under OX X and the offending patitions removed. So I ended up with one large disk and installed that way. I had mis read the information that it required a 8..... or just under 900 mb disk partition on the disk for yaboot to load. There was a boot partition that was 1 Gig and it wouldn't use it. The partitioning program was not very helpful in telling me what it wanted, it was basically a complaint and sent you back to change it. After the fdisk it seemed to go ok, but couldn't get from the shell to where the config file was. I will post that question... Next thanks for help and I will try in the future to be more explicit. I have noticed that most of the helpful people read more into what's happening that is needed, but I think that's the computer person. For instance, many asked if I had the right disk for my architecture, if not it would not have booted at all. Anyway I wish all who have read this a happy new year and hope to see them in the future....

    Jack

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •