Find the answer to your Linux question:
Results 1 to 6 of 6
As I get better at this, I have found that I have a problem in the area of specifying a device. Once installed, I have to change the yaboot config ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie jkwilborn's Avatar
    Join Date
    Nov 2012
    Posts
    196

    Install, then shell out and can't locate installed system


    As I get better at this, I have found that I have a problem in the area of specifying a device. Once installed, I have to change the yaboot config file and it's located in the /etc directory. If I shell out, from the install menu, I am apparently dumped into a 'ram disk' that the install has set up. I am having difficulty finding where my install actually went, in other words I can't cd to the new os installation. Is there a file on the ram disk that will tell me what devices are available? So I can change over there and make the proper changes? Previously, when rebooted and I need to change the yaboot config to be able to use the monitor, I used ctl-C to break out of the boot sequence, is that the proper key combination? When I have tried that lately, the file system is in a write-only mode and I can't make modifications.

    Thanks for any help that comes up...

    Jack

  2. #2
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    As I get better at this, I have found that I have a problem in the area of specifying a device
    Specifying what type of device for what purpose??

    You make reference to "install" but make no mention of what you are trying to install. Have you tried to install another OS and are unable to find its partition location? You need to be more specific about what you are doing to get any help. I'm not sure what you mean by "I can't cd to the new os installation" as one generally boots to any operating system.

    Just read your other post re the attempt to install Debian on your mac hd. Is this what you are referring to when you mention install?

  3. #3
    Linux Newbie jkwilborn's Avatar
    Join Date
    Nov 2012
    Posts
    196
    Sorry, this is the story...

    I am installing Debian 6.0.6 Linux on my G5 Mac from a install DVD that has worked in the past. I have a video card that loses video after the installation program reboots the G5, the fix is to change the yaboot.conf and run ybin before a restart. I have the information that I need to change and was breaking out of the boot process then modifying the the config file. I was having a problem with breaking out of the boot since I was using control-C and was wondering if I was using the proper 'break' characters to obtain control and modify the file.

    This originally worked and I was fixing other problems. However the hard disk seems to have had a problem and on replacement I found that during the installation of Debian, I can invoke a shell, with the thought of fixing the yaboot.conf file before the reboot. Unfortunately it seems that the installation process creates a system using a 'ramdisk', so when I went looking for the yaboot.conf file, it was not to be found. I don't know how to locate the 'installed Debian file system' to modify the yaboot config file. After the install, I attempted to boot off the DVD again, and I could not. When I break out of the boot sequence with ctl-C the file system is in read only mode and won't allow any modifications of the yaboot.conf file. This is why I was asking about some other key sequence that might give me better results.

    I was hoping that someone would know where the actual device names (used to cd or access the installed system) is maintained so I could look and see exactly what I need to do to change over to that file system and fix the required files..

    What seems odd to me is that when I hold down the 'c' key (to boot off the DVD), the prompt is from the installed Debian boot program and not the rom in the G5, so now I wonder if the DVD is not working correctly or what. If I replace the HD with the original HD from Apple and boot OS X I can read the DVD fine, so is the driver not working in Linux or is something else happening?

    I am a software hardware specialist, many years ago, so I believe I'm following the proper sequence to install Debian, but with the inability to boot off the DVD I have questions.

    Is this a more complete and useful description? If you have any other questions, just ask. Also, since the machine is not up and until it gets completely up (when I won't need this help) it is not connected to the Internet and that makes it virtually impossible to 'post' results of commands.

    Thanks
    Jack

  4. #4
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    If I understand correctly, you have installed Debian but are having problems with it and want to modify a file (yaboot.conf)? Don't know anything about yaboot. If you have Debian installed, you can find the device names with the fdisk command. From the Debian CD, you would probably need to do: sudo fdisk -l(Lower case Letter L in the command) which will show your drives/partitions. You can also get information with: df -h on partitions. df -h will show device name/number, size, filesystem type and mount point, if any.

    When I break out of the boot sequence with ctl-C the file system is in read only mode and won't allow any modifications
    That would be expected behavior when booting from the DVD as it is a read-only filesystem. If you want to modify files on the installed system, you would need to get the partition number, create a mount point and mount it and make your edits as root.

    I don't know if you are familiar with these commands? Output of fdisk command on my machine:

    fdisk -l

    Disk /dev/sda: 320.1 GB, 320072933376 bytes
    255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x1549f232

    Device Boot Start End Blocks Id System
    /dev/sda1 * 2048 206847 102400 7 HPFS/NTFS
    /dev/sda2 208845 82959659 41375407+ 7 HPFS/NTFS
    /dev/sda3 599898112 625139711 12620800 7 HPFS/NTFS
    /dev/sda4 82959721 599898111 258469195+ 5 Extended
    /dev/sda5 82959723 123282809 20161543+ 83 Linux
    /dev/sda6 123282873 127090214 1903671 82 Linux swap / Solaris
    Output of df -h on my machine:

    df -h
    Filesystem Size Used Avail Use% Mounted on
    /dev/sda8 39G 32G 5.7G 85% /
    /dev/sda9 60G 41G 16G 73% /mnt/data
    /dev/sda11 58G 25G 30G 46% /mnt/data-iso
    /dev/sda10 20G 2.3G 17G 13% /mnt/sda10
    /dev/sda12 8.4G 4.1G 3.8G 52% /mnt/sda12
    /dev/sda13 20G 5.8G 13G 31% /mnt/sda13
    /dev/sda7 20G 5.7G 13G 32% /mnt/slack
    /dev/sda5 19G 8.8G 9.3G 49% /mnt/ubuntu
    /dev/sda2 40G 18G 22G 46% /mnt/win_7
    That is just so you know what to expect. I didn't post the complete fdisk output for brevity sake which is why there are differences in partitions.

  5. #5
    Linux Newbie jkwilborn's Avatar
    Join Date
    Nov 2012
    Posts
    196
    Thanks so much, I'm sure this will assist me in my endevour. A couple of things, the original Hard Drive Debian was on started having errors that became useless to fix, so I guess it was the end of it's life. That drive was removed and discarded. I had a couple of other drives and when I installed Debian on the drive and rebooted, then broke out with CTL-C, I was on the installed drive, the DVD was removed but the file system was in 'read only' mode. I could browse all I wanted, but couldn't fix the problem since I couldn't write the fix back to the drive. I would also expect the DVD to be read only. The two commands you showed me will be in my book so thanks for that.

    What makes this a problem is when I install Debian, the video card I have ends up with the video on the ADC port (I'm assuming) instead of the DVI port where the install takes place. So at the end of the reboot, I loose video so I can't tell what the status of the machine is at that time. The fix is simple and easy, but I can't do it with no monitor.

    I also don't understand why the machine will not boot off the DVD after the install. The prompt that I see is from Linux, not the ROM of the Mac, so it must be going out and loading something off the HD. I'm going to reformat the drives and see what I can do with the supplied commands. Thanks very much...

    Can I assume that the CTL-C key is the proper break out key? Is there any that happen more quickly?

    Jack

  6. #6
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    the DVD was removed but the file system was in 'read only' mode
    That can happen if there are problems with the filesystem so you could run a filesystem check on the "/" (root of the filesystem) partition. You could search here for "run fsck on Debian" or google it.

    Don't know why it boots off the drive if you have a DVD in the drive set to first boot priority. I've never used a Mac.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •