Find the answer to your Linux question:
Results 1 to 3 of 3
Hi I have these set of problems on my Debian (KDE) knetworkmanager detected and configured the datacard (TATA Docomo 3G model: MFE631). But when I try o connect it doesn't ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2007
    Posts
    19

    TATA Docomo 3G USB Modem (India, Model: MF631) HSUPA connection issues


    Hi

    I have these set of problems on my Debian (KDE)
    knetworkmanager detected and configured the datacard (TATA Docomo 3G model: MFE631).
    But when I try o connect it doesn't connect on the first attempt. I have to manually disconnect and reconnect the modem, and also keep retstarting Knetworkmanager.
    After 4 or 5 (if I'm lucky) such attempts, it connects. Sometimes I have to connect to my roommates wireless, and then on the next 1-2 attempts this starts working.

    Recently, a new problem started. This might be more of a n/w issue though. The status is connected but I can't open any webpages. The request times out. Then I again
    connect to the wireless and visit the pages, then I can again browse with the Docomo.
    Any ideas on how to proceed?

    Things I have/had tried:
    TATA DOCOMO application doesn't even detect the device.
    usb mode switch is working fine (I think).
    I used to have a wvdial based thing working, previously. But then I had to configure a wireline also. After that, wvdial doesn't connect even after I replaced the old wvdial.conf file.
    It connects and immediately disconnects. I can't post message now, as I don't a n/w disruption right now .
    I don't want to switch to Gnome, so most of the Ubuntu forums are out, they have Gnome/Ubuntu specific fixes. On Debian I'm still searching. Though I'm not even sure how to describe the problem.

    If anybody here has any ideas, pls do help.

    Thanks in Adv.

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,755
    Possibly it isn't properly configured. Normally, a USB modem (3g or otherwise) will appear to the system as a standard USB modem, so you would use the Mobile Broadband network manager settings.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Sep 2007
    Posts
    19
    Quote Originally Posted by Rubberman View Post
    ... you would use the Mobile Broadband network manager settings.
    Yes that's what I did. If it is of any help, I am adding the lsusb and sb-debices output:
    Code:
    $ lsusb
    Bus 002 Device 004: ID 04f2:b044 Chicony Electronics Co., Ltd Acer CrystalEye Webcam
    Bus 002 Device 003: ID 19d2:2000 ONDA Communication S.p.A. ZTE MF627/MF628/MF628+/MF636+ HSDPA/HSUPA
    Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    $ eject /dev/sr1 
    $ lsusb
    Bus 002 Device 009: ID 19d2:2003 ONDA Communication S.p.A.
    Bus 002 Device 004: ID 04f2:b044 Chicony Electronics Co., Ltd Acer CrystalEye Webcam
    Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    $ usb-devices | grep -A8 -b4 -i zte
    1292-
    1293-T:  Bus=02 Lev=02 Prnt=02 Port=02 Cnt=01 Dev#=  9 Spd=480 MxCh= 0
    1359-D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
    1420-P:  Vendor=19d2 ProdID=2003 Rev=00.00
    1458:S:  Manufacturer=ZTE,Incorporated
    1492:S:  Product=ZTE WCDMA Technologies MSM
    1531:S:  SerialNumber=MF6310ZTED010000
    1565-C:  #Ifs= 5 Cfg#= 1 Atr=e0 MxPwr=500mA
    1604-I:  If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
    1673-I:  If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
    1742-I:  If#= 2 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
    1811-I:  If#= 3 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
    1880-I:  If#= 4 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
    1954-
    1955-T:  Bus=02 Lev=02 Prnt=02 Port=04 Cnt=02 Dev#=  4 Spd=480 MxCh= 0

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •