Find the answer to your Linux question:
Results 1 to 6 of 6
Hello, I have Debian 6.0.6 with an i3450 Cpu. I noticed that after a while that monitor was very high. So when I looked at the monitor, it showed 100% ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User jkwilborn's Avatar
    Join Date
    Nov 2012
    Posts
    258

    cpu stuck at 100%


    Hello, I have Debian 6.0.6 with an i3450 Cpu. I noticed that after a while that monitor was very high. So when I looked at the monitor, it showed 100% on 3 of 4 CPU's. I looked at whom is doing this but all were some type of daemon with a name like flush:[other number].

    I let it run for a number of hours and the processes never quit and I'm convinced that they should have been done as there was disk activity.


    Anyone know why how or how to stop them without re-booting?

    Thanks

    Jack

  2. #2
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,570
    This looks like an answer although not too much of one I'm afraid...
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    The Fifth Continent

  3. #3
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,599
    As per the link that elija posted, it may be a kernel bug. What kernel are you running? Also, what about applications on the system? If something is writing a lot to disc unnecessarily (stuck in a write loop perhaps), then this can happen as well.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  4. #4
    Just Joined!
    Join Date
    Sep 2012
    Posts
    8
    First check your disk space, particualrly the swap file(s).
    I ran into a similar problem with disk thrashing and the machine freezing only to find out that my LMDE install did not turn on the swap.

    Some apps are sloppy with memory, and will gunk up a machine after a couple of days, basically forcing a reboot.

    What I use here is:

    sync; echo 3 > /proc/sys/vm/drop_caches
    /sbin/swapoff -a
    /sbin/swapon -a

    First make sure your swap partition(s) are in fstab.
    And then wait a couple of minutes as the swap partition(s) empty.

    This dumps the write caches to disk, and flushes out unneeded memory, and then empties the swap (virtual) memory.
    For many the first line alone would be enough (a quick process).

    The last two lines delete (turn off) and then turn back on swap.

  5. #5
    Linux User jkwilborn's Avatar
    Join Date
    Nov 2012
    Posts
    258
    klachman, thanks for the input, I will try that. It seems that I was trying to format a memory stick and it had problems formatting (see elsewhere where I posted this problem) and when I looked at what was running it was a 'flush' type of daemon. My guess is it got hung up, but I'm not sure. It doesn't seem to happen when I have a successful format so I'm leaning towards that scenario. I was hoping that someone would post a possible solution, like you did.

    I will apply your solution next time this thing comes up and will also ensure that the previous operations are working properly and not failing somehow. Although if it fails I would hope it would recover properly.

    Thanks again.... I've written you solution down in my command book!

    Jack

  6. #6
    Just Joined!
    Join Date
    Sep 2012
    Posts
    8
    Then check to see if pdflush is on your system, and possibly if there is a newer version.

    I found a couple of good links, but the system here wont let me post them .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •