Find the answer to your Linux question:
Results 1 to 7 of 7
Hai, When I start the system, sometimes I get login prompt and sometimes I get KDM display manager. I dont know why is this happening? How Should I fix this ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Posts
    30

    Display manager works sometimes


    Hai,

    When I start the system, sometimes I get login prompt and sometimes I get KDM display manager. I dont know why is this happening? How Should I fix this problem so that I should get GUI, whenever I start the machine.

    Thanks
    Sunil.

  2. #2
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    When you say
    How Should I fix this problem so that I should get GUI, whenever I start the machine.
    Do you meen you have the shell sometimes?
    if you're able to get into KDE then go in the control center and ENABLE GUI interface at boot...

    of go in /etc/inittab and edit this
    Code:
    id:5:initdefault:
    set it to 5 since 5 is the setting for graphical interface at boot

    Hope you get this settle
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  3. #3
    Just Joined!
    Join Date
    Dec 2004
    Posts
    30
    Do you meen you have the shell sometimes?
    Yes.

    And I was able to find a work around to get into KDE by setting gdm as default in display manager file and then while logging in I chose KDE session and I was able to get into KDE.

    I went into KDE environment, Control Center but i didnt find ENABLE GUI interface at boot option. Where Should I go in Control Center for ENABLE GUI option.

    Thanks for your help
    sunil

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Dec 2004
    Posts
    30
    Code:
    of go in /etc/inittab and edit this 
    Code:
    id:5:initdefault:
    set it to 5 since 5 is the setting for graphical interface at boot
    I tried this thing but it didnt work.

    About the workaround, i.e. by changing defualt display manger to gdm the GUI prompt doesnt show up directly. First I get a blank screen, then its goes to Shell prompt and after 3-5 seconds I will get gdm gui. I dont know why is it acting so different but wanted to let you about this.

    Thanks
    Sunil.

  6. #5
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    I had the same problem in MDK when I change mu Xorg config file... whenever the file change (ex: changed the default reasolution) I booted up in terminal...

    Did you made any modifications? if not try to remove the rw option to this file for your user...
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  7. #6
    Just Joined!
    Join Date
    Dec 2004
    Posts
    30
    Yes, I changed the settings when I first logged onto the KDE using root login. I went to control center and changed Apperance, Desktop, Power control and certain other options in Control Center.

    if not try to remove the rw option to this file for your user...
    Which file do you want me to change the rw permission?

    Sunil

  8. #7
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    If KDE, its xf86Config, xorg or xf86Config-4
    for gnome.. I never used it..
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •